aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/foo2zjs
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/foo2zjs
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/foo2zjs')
-rw-r--r--unmaintained/foo2zjs/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/unmaintained/foo2zjs/APKBUILD b/unmaintained/foo2zjs/APKBUILD
new file mode 100644
index 0000000000..a863665fbf
--- /dev/null
+++ b/unmaintained/foo2zjs/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=foo2zjs
+pkgver=20150704
+pkgrel=0
+pkgdesc="a linux printer driver for XQX stream protocol"
+url="http://foo2xqx.rkkda.com/"
+arch="all"
+license="GPL"
+depends=""
+depends_dev=""
+makedepends="$depends_dev ghostscript-dev bc coreutils groff cups-dev
+ foomatic-db-engine"
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::http://foo2zjs.rkkda.com/foo2zjs.tar.gz"
+
+_builddir="$srcdir/$pkgname"
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make -j1 || return 1
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr/lib/cups/filter/
+ make -j1 DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="2c16316720c1cc29fb3644284e2a57b7 foo2zjs-20150704.tar.gz"
+sha256sums="6ba509fd20e70ec511f48e7627ffa1bb14d8cbe390a71923e00c10e649000e8b foo2zjs-20150704.tar.gz"
+sha512sums="33ae74428f9d100723a4aae96a678ba818a2e72c34de1d2ea7eeb1b39b8633d1c380e067a15e63ebe38d54e5483e61d2c936cdf8541b0b085d6f844540f0febc foo2zjs-20150704.tar.gz"