aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/git-lfs
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/git-lfs
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/git-lfs')
-rw-r--r--unmaintained/git-lfs/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/unmaintained/git-lfs/APKBUILD b/unmaintained/git-lfs/APKBUILD
new file mode 100644
index 0000000000..840101b918
--- /dev/null
+++ b/unmaintained/git-lfs/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
+pkgname=git-lfs
+pkgver=1.1.0
+pkgrel=0
+pkgdesc="Git extension for versioning large files"
+url="https://git-lfs.github.com/"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="go"
+install=""
+subpackages="$pkgname-doc"
+options="!strip"
+source="$pkgname-$pkgver.tar.gz::https://github.com/github/$pkgname/archive/v$pkgver.tar.gz"
+
+_builddir="$srcdir"/src/github.com/github
+prepare() {
+ mkdir -p "$_builddir"
+ ln -s "$srcdir"/$pkgname-$pkgver "$_builddir"/$pkgname || return 1
+}
+
+build() {
+ cd "$_builddir"/$pkgname
+ GOPATH="$srcdir" go build || return 1
+
+ # TODO man page generation would require ronn which isn't packaged yet.
+ # sh ./script/man
+}
+
+package() {
+ cd "$_builddir"/$pkgname
+ install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname || return 1
+
+ mkdir -p "$pkgdir"/usr/share/doc/$pkgname
+ for file in api extensions.md spec.md README.md; do
+ mv docs/$file "$pkgdir"/usr/share/doc/$pkgname/ || return 1
+ done
+}
+
+md5sums="089b5f215789437e8bc12915fb5d883f git-lfs-1.1.0.tar.gz"
+sha256sums="1f246ec5f1141677b05847b3e9bcb9929c9d9b1afc78585d5776a9c18186ea9b git-lfs-1.1.0.tar.gz"
+sha512sums="4a5d379db165ced3c2d536f51d2729dbc7be4f0e8f1e2e6d9659ee1cba9978bdc5a83d7a90e2c91ffd5ff78d0fc328539f2e18b641c10505a16743590829da56 git-lfs-1.1.0.tar.gz"