aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/gnome-themes-standard
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/gnome-themes-standard
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/gnome-themes-standard')
-rw-r--r--unmaintained/gnome-themes-standard/APKBUILD60
1 files changed, 60 insertions, 0 deletions
diff --git a/unmaintained/gnome-themes-standard/APKBUILD b/unmaintained/gnome-themes-standard/APKBUILD
new file mode 100644
index 0000000000..c16541258c
--- /dev/null
+++ b/unmaintained/gnome-themes-standard/APKBUILD
@@ -0,0 +1,60 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gnome-themes-standard
+pkgver=3.16.2
+pkgrel=0
+pkgdesc="Default themes for the GNOME desktop"
+url="http://www.gnome.org"
+arch="all"
+license="GPL2"
+depends="adwaita-gtk2-theme"
+depends_dev="gtk+3.0-dev librsvg-dev"
+makedepends="$depends_dev intltool"
+install=""
+subpackages="$pkgname-lang adwaita-gtk2-theme:_gtk2"
+source="http://ftp.gnome.org/pub/GNOME/sources/gnome-themes-standard/${pkgver%.*}/gnome-themes-standard-$pkgver.tar.xz"
+
+_builddir="$srcdir"/gnome-themes-standard-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ DATADIRNAME=share \
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+_gtk2() {
+ pkgdesc="Adwaita gtk2 theme"
+ depends=""
+ mkdir -p "$subpkgdir"/usr/share/themes/Adwaita \
+ "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/share/themes/Adwaita/gtk-2.0 \
+ "$subpkgdir"/usr/share/themes/Adwaita || return 1
+ mv "$pkgdir"/usr/lib/gtk-2.0 "$subpkgdir"/usr/lib || return 1
+}
+
+md5sums="0d80ad7786cfd498c966361ba2e790c7 gnome-themes-standard-3.16.2.tar.xz"
+sha256sums="59eb79a59d44b5cd8daa8de1e7559fb5186503dcd78e47d0b72cb896d8654b9f gnome-themes-standard-3.16.2.tar.xz"
+sha512sums="483e63e1f01d6a0c26a07def12f19d59406a2f89202db599876cff8542215b4d5eb8a054805eb16a4e027c76399f4bb498ed326e136ecf482c71f5a0b8cb5556 gnome-themes-standard-3.16.2.tar.xz"