aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/gpm
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/gpm
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/gpm')
-rw-r--r--unmaintained/gpm/01-Iheaders.patch40
-rw-r--r--unmaintained/gpm/02-sys-select.patch138
-rw-r--r--unmaintained/gpm/03-gpmroot.patch39
-rw-r--r--unmaintained/gpm/APKBUILD90
-rw-r--r--unmaintained/gpm/error-format.patch13
-rw-r--r--unmaintained/gpm/gpm.confd8
-rw-r--r--unmaintained/gpm/gpm.initd10
7 files changed, 338 insertions, 0 deletions
diff --git a/unmaintained/gpm/01-Iheaders.patch b/unmaintained/gpm/01-Iheaders.patch
new file mode 100644
index 0000000000..e0f2892d98
--- /dev/null
+++ b/unmaintained/gpm/01-Iheaders.patch
@@ -0,0 +1,40 @@
+commit 462cd6c81a2321872a5807e652780eb90a0fb40e
+Author: Isaac Dunham <ibid.ag@gmail.com>
+Date: Tue Jul 15 14:39:37 2014 -0700
+
+ Add -Iheaders so we can find gpm.h
+
+diff --git a/src/Makefile.in b/src/Makefile.in
+index d3b1dcd..1f8a4dc 100644
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -65,7 +65,7 @@ prog/%: prog/%.o
+ $(CC) @LDFLAGS@ $(LDFLAGS) -o $@ $^ @LIBS@ $(LIBS)
+
+ %.o: %.c
+- $(CC) @CPPFLAGS@ $(CPPFLAGS) @CFLAGS@ $(CFLAGS) -c -o $@ $<
++ $(CC) -Iheaders @CPPFLAGS@ $(CPPFLAGS) @CFLAGS@ $(CFLAGS) -c -o $@ $<
+
+ %.lo: %.c
+ $(CC) @CPPFLAGS@ $(CPPFLAGS) @PICFLAGS@ @CFLAGS@ $(CFLAGS) -c -o $@ $<
+@@ -96,7 +96,7 @@ $(DEPFILE) dep: prog/gpm-root.c
+
+ # create dependencies
+ for DEPS in `echo *.c */*.c`; do \
+- $(CC) -I. -I $(srcdir) -M @CPPFLAGS@ $(CPPFLAGS) $$DEPS | \
++ $(CC) -I. -Iheaders -I $(srcdir) -M @CPPFLAGS@ $(CPPFLAGS) $$DEPS | \
+ $(SED) 's/^\(.*\)\.o\([ :]+\)/\1.o \1.lo\2/g' >> $(DEPFILE) ; done
+
+ ### INSTALL
+diff --git a/src/daemon/open_console.c b/src/daemon/open_console.c
+index 98297c9..f7df875 100644
+--- a/src/daemon/open_console.c
++++ b/src/daemon/open_console.c
+@@ -22,6 +22,7 @@
+ #include <fcntl.h> /* open and co. */
+ #include <sys/stat.h> /* stat() */
+ #include <sys/ioctl.h> /* ioctl */
++#include <sys/sysmacros.h> /* major() */
+
+ /* Linux specific (to be outsourced in gpm2 */
+ #include <linux/serial.h> /* for serial console check */
diff --git a/unmaintained/gpm/02-sys-select.patch b/unmaintained/gpm/02-sys-select.patch
new file mode 100644
index 0000000000..31c4ed0660
--- /dev/null
+++ b/unmaintained/gpm/02-sys-select.patch
@@ -0,0 +1,138 @@
+commit 6d05d3d02fac411080363665e1c4fc7a2c84f7aa
+Author: Isaac Dunham <ibid.ag@gmail.com>
+Date: Tue Jul 15 17:11:04 2014 -0700
+
+ Add sys/select.h to headers
+
+diff --git a/src/daemon/old_main.c b/src/daemon/old_main.c
+index 9cd4e56..0ea0b84 100644
+--- a/src/daemon/old_main.c
++++ b/src/daemon/old_main.c
+@@ -26,6 +26,7 @@
+ #include <errno.h> /* guess again */
+ #include <unistd.h> /* unlink */
+ #include <sys/stat.h> /* chmod */
++#include <sys/select.h> /* fd_set, FD_ZERO */
+
+ #include <linux/kd.h> /* linux hd* */
+
+diff --git a/src/daemon/processmouse.c b/src/daemon/processmouse.c
+index b3f3994..af3400a 100644
+--- a/src/daemon/processmouse.c
++++ b/src/daemon/processmouse.c
+@@ -30,6 +30,7 @@
+ #include <unistd.h> /* close */
+ #include <time.h> /* time */
+ #include <sys/time.h> /* gettimeofday */
++#include <sys/select.h> /* FD_ZERO */
+
+ #include "headers/message.h" /* messaging in gpm */
+ #include "headers/daemon.h" /* daemon internals */
+diff --git a/src/lib/libcurses.c b/src/lib/libcurses.c
+index e7ebf84..e6fa877 100644
+--- a/src/lib/libcurses.c
++++ b/src/lib/libcurses.c
+@@ -26,6 +26,7 @@
+ #include <unistd.h> /* select(); */
+ #include <sys/time.h> /* timeval */
+ #include <sys/types.h> /* socket() */
++#include <sys/select.h> /* FD_ZERO */
+
+ #include "headers/gpmInt.h"
+
+diff --git a/src/lib/liblow.c b/src/lib/liblow.c
+index e789d09..e449321 100644
+--- a/src/lib/liblow.c
++++ b/src/lib/liblow.c
+@@ -35,6 +35,7 @@
+ #include <sys/un.h> /* struct sockaddr_un */
+ #include <sys/fcntl.h> /* O_RDONLY */
+ #include <sys/stat.h> /* stat() */
++#include <sys/select.h> /* FD_ZERO */
+
+ #ifdef SIGTSTP /* true if BSD system */
+ #include <sys/file.h>
+diff --git a/src/lib/libxtra.c b/src/lib/libxtra.c
+index e6dd4aa..b7ec631 100644
+--- a/src/lib/libxtra.c
++++ b/src/lib/libxtra.c
+@@ -25,6 +25,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <sys/time.h>
++#include <sys/select.h>
+ #include <sys/types.h>
+ #include <unistd.h>
+ #include <string.h>
+diff --git a/src/mice.c b/src/mice.c
+index 6cbd491..6989f92 100644
+--- a/src/mice.c
++++ b/src/mice.c
+@@ -55,6 +55,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h> /* stat() */
+ #include <sys/time.h> /* select() */
++#include <sys/select.h> /* select() */
+
+ #include <linux/kdev_t.h> /* MAJOR */
+ #include <linux/keyboard.h>
+diff --git a/src/prog/display-buttons.c b/src/prog/display-buttons.c
+index de8e5b2..2385bf0 100644
+--- a/src/prog/display-buttons.c
++++ b/src/prog/display-buttons.c
+@@ -37,6 +37,7 @@
+ #include <time.h> /* time() */
+ #include <errno.h> /* errno */
+ #include <gpm.h> /* gpm information */
++#include <sys/select.h> /* FD_ZERO */
+
+ /* display resulting data */
+ int display_data(Gpm_Event *event, void *data)
+diff --git a/src/prog/display-coords.c b/src/prog/display-coords.c
+index ed15c8a..5aa7228 100644
+--- a/src/prog/display-coords.c
++++ b/src/prog/display-coords.c
+@@ -37,6 +37,7 @@
+ #include <stdio.h> /* printf() */
+ #include <time.h> /* time() */
+ #include <errno.h> /* errno */
++#include <sys/select.h> /* FD_ZERO() */
+ #include <gpm.h> /* gpm information */
+
+ /* display resulting data */
+diff --git a/src/prog/mev.c b/src/prog/mev.c
+index 97622d4..22cfb05 100644
+--- a/src/prog/mev.c
++++ b/src/prog/mev.c
+@@ -36,6 +36,7 @@
+ #include <signal.h>
+ #include <sys/types.h>
+ #include <sys/time.h>
++#include <sys/select.h>
+ #include <unistd.h>
+ #include <termios.h>
+ #include <errno.h>
+diff --git a/src/prog/mouse-test.c b/src/prog/mouse-test.c
+index 0bb1982..9a1b624 100644
+--- a/src/prog/mouse-test.c
++++ b/src/prog/mouse-test.c
+@@ -37,6 +37,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <sys/time.h>
++#include <sys/select.h>
+ #include <fcntl.h>
+ #include <time.h>
+ #include <signal.h>
+diff --git a/src/synaptics.c b/src/synaptics.c
+index 2418c75..ea40a53 100644
+--- a/src/synaptics.c
++++ b/src/synaptics.c
+@@ -216,6 +216,7 @@
+ #include <string.h>
+ #include <sys/time.h>
+ #include <sys/ioctl.h>
++#include <sys/select.h>
+
+ #include "headers/gpm.h"
+ #include "headers/daemon.h" /* which_mouse */
diff --git a/unmaintained/gpm/03-gpmroot.patch b/unmaintained/gpm/03-gpmroot.patch
new file mode 100644
index 0000000000..bbfdfc7028
--- /dev/null
+++ b/unmaintained/gpm/03-gpmroot.patch
@@ -0,0 +1,39 @@
+commit 9b66298a4262bfd90f3701c7f48c9dcf7a157cac
+Author: Isaac Dunham <ibid.ag@gmail.com>
+Date: Thu Feb 11 16:54:32 2016 -0800
+
+ make gpm-root build
+
+ * use sigemptyset() instead of nonportable equivalents
+ * if SA_INTERRUPT is undefined, set sa_flags to 0 because the implementation
+ defaults to interrupt mode (thanks to nsz for pointing out missing
+ initialization)
+
+diff --git a/src/prog/gpm-root.y b/src/prog/gpm-root.y
+index 069d801..ed363f4 100644
+--- a/src/prog/gpm-root.y
++++ b/src/prog/gpm-root.y
+@@ -76,6 +76,10 @@
+ #undef YYDEBUG
+ #endif
+
++#ifndef SA_INTERRUPT
++#define SA_INTERRUPT 0
++#endif
++
+ #define USER_CFG ".gpm-root"
+ #define SYSTEM_CFG SYSCONFDIR "/gpm-root.conf"
+
+@@ -1196,11 +1200,7 @@ int main(int argc, char **argv)
+ LOG_DAEMON : LOG_USER);
+ /* reap your zombies */
+ childaction.sa_handler=reap_children;
+-#if defined(__GLIBC__)
+- __sigemptyset(&childaction.sa_mask);
+-#else /* __GLIBC__ */
+- childaction.sa_mask=0;
+-#endif /* __GLIBC__ */
++ sigemptyset(&childaction.sa_mask);
+ childaction.sa_flags=SA_INTERRUPT; /* need to break the select() call */
+ sigaction(SIGCHLD,&childaction,NULL);
+
diff --git a/unmaintained/gpm/APKBUILD b/unmaintained/gpm/APKBUILD
new file mode 100644
index 0000000000..d80c54bb0c
--- /dev/null
+++ b/unmaintained/gpm/APKBUILD
@@ -0,0 +1,90 @@
+# Contributor: Jeff Pohlmeyer <yetanothergeek@gmail.com>
+# Maintainer: Jeff Pohlmeyer <yetanothergeek@gmail.com>
+pkgname=gpm
+pkgver=1.20.7
+pkgrel=3
+pkgdesc="A mouse server for the console"
+url="http://www.nico.schottelius.org/software/gpm/"
+arch="all"
+license="GPL"
+depends=""
+depends_dev="$pkgname-libs"
+makedepends="$depends_dev texinfo autoconf automake libtool bison linux-headers ncurses-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-utils"
+source="http://www.nico.schottelius.org/software/gpm/archives/$pkgname-$pkgver.tar.bz2
+ error-format.patch
+ 01-Iheaders.patch
+ 02-sys-select.patch
+ 03-gpmroot.patch
+ $pkgname.initd
+ $pkgname.confd
+ "
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./autogen.sh
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+
+ install -m755 -D "$srcdir"/$pkgname.initd \
+ "$pkgdir"/etc/init.d/$pkgname || return 1
+ install -m644 -D "$srcdir"/$pkgname.confd \
+ "$pkgdir"/etc/conf.d/$pkgname || return 1
+
+ chmod 755 "$pkgdir"/usr/lib/libgpm.so.*
+}
+
+utils() {
+ depends="$pkgname"
+ pkgdesc="Mouse utilities for console"
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/ || return 1
+ rmdir "$pkgdir"/usr/lib || return 1
+}
+
+md5sums="bf84143905a6a903dbd4d4b911a2a2b8 gpm-1.20.7.tar.bz2
+ba7ffe9a3b6e3f672081a5b7d17f4766 error-format.patch
+3adbe10e28d14d5b498a83bbccbba427 01-Iheaders.patch
+6b6ef5234d6903c666e0f12eb8a1b958 02-sys-select.patch
+e248dda6c8fb4dae5262a3e15cadb1c9 03-gpmroot.patch
+c2d6e7341dc2bd285e276b14336b4bf6 gpm.initd
+887ce2e3743ac8ea9baf9f723876dc4b gpm.confd"
+sha256sums="f011b7dc7afb824e0a017b89b7300514e772853ece7fc4ee640310889411a48d gpm-1.20.7.tar.bz2
+290e032640c8cfb95d5a8dddfd99e11887100b08750b9f5ceaec6e3209e3ebf3 error-format.patch
+4b99946b86d9f21d7ec4f3e366dab18a57133903c480408bf0eb838fccc2f11d 01-Iheaders.patch
+04487ddfe3e2f5ada548d55bc0e62bf5f36e92641d254f4f24ee0428253b26a5 02-sys-select.patch
+48a60c2661f675cc17c6fdc7d2f55f8836624df3c1c490160a321e846a9925aa 03-gpmroot.patch
+d3b6ba9da912f628572d9679311f562a2fb318765ae7397da535df830ccd09ba gpm.initd
+260b40ffebc7eca901203ca7083cfd72a8ffb5da7210840b389ddc2317e80dba gpm.confd"
+sha512sums="51c1141ed502f8b6bc846485a8e315bafe3cf2b7c9d1ea8a710d9748ff2058f29c7ab5715fc1730a8437c613181d2050f37b134e9288c69ba8ff7fb0be7ec0d1 gpm-1.20.7.tar.bz2
+caad0472374b9bb9bdf8f31480f88895b2d65dc0565611932fa185592ffcc18065bb66b433f54f0df9f6173056b6c34ec5d57f79bd19f38edefeca57603bc76c error-format.patch
+cb9fa2c48b5fa7f06ccfa8be57e421ee228b49707027094a2fdca5809407e7e277484c820ed4ee0800ef1a36bfc322ac33b2f29b4411ffab345c900931113863 01-Iheaders.patch
+24fbc48408388a7481dadbccc6da3edbd5f82a644460e5a9ca6039fbac2d2eff6c16002b2158c1955fbd2677655b8b1acd1e12b94b9c29eeddb1a883e813e2a7 02-sys-select.patch
+e6bdef0847e06bb4fd15bae315cd8cdbdc5b02e7241da575127592689aad6da1b331e4442a70ae6fcb8068e844adf2de509f61c318572a91b97ab00efa6444fd 03-gpmroot.patch
+d268504bd0cf83706863a8af5c5719b0d192c34ae6a78ff0378521841eca242b39a6e6891080a5fc5512732f84e7439697ba92bfda3ecc1aaebd36b16e946477 gpm.initd
+0e7c96f29222d33301fc9c5c8cf409b7dbe6cbb1e79d76444ae5724e8b793679d3ea597a8ad64187e85680799847632095e469445ae56f893616cb0235a29f3a gpm.confd"
diff --git a/unmaintained/gpm/error-format.patch b/unmaintained/gpm/error-format.patch
new file mode 100644
index 0000000000..8c9628f492
--- /dev/null
+++ b/unmaintained/gpm/error-format.patch
@@ -0,0 +1,13 @@
+diff --git a/src/lib/report-lib.c b/src/lib/report-lib.c
+index c0ae086..1b9754d 100644
+--- a/src/lib/report-lib.c
++++ b/src/lib/report-lib.c
+@@ -47,7 +47,7 @@ void gpm_report(int line, char *file, int stat, char *text, ... )
+ log_level = LOG_CRIT; break;
+ }
+ #ifdef HAVE_VSYSLOG
+- syslog(log_level, string);
++ syslog(log_level, "%s", string);
+ vsyslog(log_level, text, ap);
+ #else
+ fprintf(stderr,"%s[%s(%d)]:\n",string,file,line);
diff --git a/unmaintained/gpm/gpm.confd b/unmaintained/gpm/gpm.confd
new file mode 100644
index 0000000000..eb77c711fe
--- /dev/null
+++ b/unmaintained/gpm/gpm.confd
@@ -0,0 +1,8 @@
+# gpm conf.d file for alpine linux
+
+#
+# Specify gpm mouse daemon options here.
+#
+
+#gpm_opts="-m /dev/input/mice -t imps2"
+
diff --git a/unmaintained/gpm/gpm.initd b/unmaintained/gpm/gpm.initd
new file mode 100644
index 0000000000..85b292c317
--- /dev/null
+++ b/unmaintained/gpm/gpm.initd
@@ -0,0 +1,10 @@
+#!/sbin/openrc-run
+
+pidfile=/var/run/gpm.pid
+command=/usr/sbin/gpm
+command_args=${gpm_opts:--m /dev/input/mice -t imps2}
+
+depend() {
+ after localmount
+ use hotplug logger
+}