aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/gst-plugin-libde265_0.10
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/gst-plugin-libde265_0.10
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/gst-plugin-libde265_0.10')
-rw-r--r--unmaintained/gst-plugin-libde265_0.10/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/unmaintained/gst-plugin-libde265_0.10/APKBUILD b/unmaintained/gst-plugin-libde265_0.10/APKBUILD
new file mode 100644
index 0000000000..782a46612d
--- /dev/null
+++ b/unmaintained/gst-plugin-libde265_0.10/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=gst-plugin-libde265_0.10
+pkgver=0.1.11
+pkgrel=0
+pkgdesc="Libde265 gstreamer plugin"
+url="https://github.com/strukturag/gstreamer-libde265"
+arch="all"
+license="LGPL"
+depends=""
+depends_dev="gstreamer0.10-dev gst-plugins-base0.10-dev gst-plugins-bad0.10-dev
+ bzip2-dev libde265-dev"
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="https://github.com/strukturag/gstreamer-libde265/releases/download/v$pkgver/gstreamer-libde265-$pkgver.tar.gz"
+
+_builddir="$srcdir"/gstreamer-libde265-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ update_config_sub || return 1
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --enable-gstreamer0.10 \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="7d855cccc653f296ec0a2c3f3c216c9f gstreamer-libde265-0.1.11.tar.gz"
+sha256sums="59e987e4ee985cc8b712936990c4d7a94d469d905d137f85f4ca5f7363d1d5b1 gstreamer-libde265-0.1.11.tar.gz"
+sha512sums="66241bb956487db65fab903ab2bbee481fc7eb6859cfbbac4ea1c0422acaff23c312defdae83fd4e7615d4f09dcdf26c68887df96ddb1b6c350692a51df6e177 gstreamer-libde265-0.1.11.tar.gz"