aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/gthumb/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/gthumb/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/gthumb/APKBUILD')
-rw-r--r--unmaintained/gthumb/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/unmaintained/gthumb/APKBUILD b/unmaintained/gthumb/APKBUILD
new file mode 100644
index 0000000000..59b76127dd
--- /dev/null
+++ b/unmaintained/gthumb/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
+# Maintainer:
+pkgname=gthumb
+pkgver=3.4.0
+pkgrel=0
+pkgdesc="gThumb is an image viewer and browser for GNOME"
+url="https://wiki.gnome.org/Apps/gthumb"
+arch="all"
+license="GPL"
+depends="gsettings-desktop-schemas"
+depends_dev=""
+makedepends="gtk+3.0-dev libintl exiv2 intltool libraw-dev flex docbook-xsl\
+ tiff-dev libgnome gstreamer1-dev glib-dev gconf libunique-dev \
+ itstool gsettings-desktop-schemas"
+install=""
+subpackages="$pkgname-lang $pkgname-doc"
+source="http://ftp.acc.umu.se/pub/gnome/sources/${pkgname}/${pkgver/\.0/}/${pkgname}-${pkgver}.tar.xz"
+
+_builddir=${srcdir}/${pkgname}-${pkgver}
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --disable-schemas-compile
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="c920d76705094141a339c97b9df8d3e7 gthumb-3.4.0.tar.xz"
+sha256sums="abd1afe457c65289af31c6db7037452faa3838356480857d8cdc19f0ecde4933 gthumb-3.4.0.tar.xz"
+sha512sums="04b962ada75ab46a6be2ad192dfc9b34bd5f7b0189d970e688d0ec89130a766ab7e5a23d34b305829092c3b8756baad83d0367f4a972e384dac16fcff0255d85 gthumb-3.4.0.tar.xz"