aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/hardlink
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/hardlink
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/hardlink')
-rw-r--r--unmaintained/hardlink/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/unmaintained/hardlink/APKBUILD b/unmaintained/hardlink/APKBUILD
new file mode 100644
index 0000000000..76b1848e74
--- /dev/null
+++ b/unmaintained/hardlink/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Valery McHno <anarch.linux@gmail.com>
+pkgname=hardlink
+pkgver=0.3.0
+pkgrel=0
+pkgdesc="Finds multiple copies of files and replaces them with hardlinks"
+url="http://jak-linux.org/projects/hardlink/"
+arch="all"
+license="MIT"
+depends=""
+makedepends="pcre musl-dev attr-dev"
+subpackages="$pkgname-doc"
+source="http://jak-linux.org/projects/hardlink/${pkgname}_${pkgver}.tar.xz"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="72f1a460adb6874c151deab766e434ad hardlink_0.3.0.tar.xz"
+sha256sums="e8c93dfcb24aeb44a75281ed73757cb862cc63b225d565db1c270af9dbb7300f hardlink_0.3.0.tar.xz"
+sha512sums="22a8945ce5dac74b05bb1231959823aec0cd364d6db9ad808df4acf232d894170c006ac1e88509604ce1859d41bd4a5d91e2b12c8010aa7fc7e19a77922c4486 hardlink_0.3.0.tar.xz"