aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/hexcurse
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/hexcurse
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/hexcurse')
-rw-r--r--unmaintained/hexcurse/APKBUILD46
-rw-r--r--unmaintained/hexcurse/hexcurse-alloca.patch14
2 files changed, 60 insertions, 0 deletions
diff --git a/unmaintained/hexcurse/APKBUILD b/unmaintained/hexcurse/APKBUILD
new file mode 100644
index 0000000000..7bf023913b
--- /dev/null
+++ b/unmaintained/hexcurse/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=hexcurse
+pkgver=1.55
+pkgrel=0
+pkgdesc="Versatile ncurses-based hex editor"
+url="http://directory.fsf.org/project/HexCurse"
+arch="all"
+license="GPL"
+depends=
+depends_dev="ncurses-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://gd.tuwien.ac.at/opsys/linux/gentoo/distfiles/hexcurse-$pkgver.tar.gz
+ hexcurse-alloca.patch"
+
+_builddir="$srcdir"/hexcurse-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="c9f9485490300b5111aa429eabfef789 hexcurse-1.55.tar.gz
+5aae74a76923ee8e4fe033e0aa381a82 hexcurse-alloca.patch"
diff --git a/unmaintained/hexcurse/hexcurse-alloca.patch b/unmaintained/hexcurse/hexcurse-alloca.patch
new file mode 100644
index 0000000000..2ea060f2d8
--- /dev/null
+++ b/unmaintained/hexcurse/hexcurse-alloca.patch
@@ -0,0 +1,14 @@
+--- hexcurse/src/getopt.c 2002-03-21 17:55:54.000000000 +0100
++++ hexcurse/src/getopt.c 2004-08-09 12:52:39.592951560 +0200
+@@ -36,8 +36,8 @@
+ * enables hexcurse to be compiled with SGI's proprietary compiler */
+ #ifdef _SGIAPI
+ #include <alloca.h>
+-#else
+-char *alloca ();
++//#else
++//char *alloca ();
+ #endif
+ #define __alloca alloca
+ /* end of modification */
+