aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/httpup/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/httpup/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/httpup/APKBUILD')
-rw-r--r--unmaintained/httpup/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/unmaintained/httpup/APKBUILD b/unmaintained/httpup/APKBUILD
new file mode 100644
index 0000000000..166573fe6e
--- /dev/null
+++ b/unmaintained/httpup/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: z3bra <willy at mailoo dot org>
+# Maintainer:
+pkgname=httpup
+pkgver=0.4.0l
+pkgrel=0
+pkgdesc="One way sync over http (CRUX port)"
+url="http://jw.tks6.net/files/crux/${pkgname}_manual.html"
+arch="all"
+license="GPL"
+depends="curl"
+depends_dev="curl-dev"
+makedepends="$depends_dev"
+subpackages="httpup-doc"
+source="http://jw.tks6.net/files/crux/$pkgname-$pkgver.tar.gz
+ 10-getcwd.patch"
+
+_builddir=$srcdir/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+
+ sed -i 's/usr/local/usr' Makefile
+}
+
+build() {
+ cd "$_builddir"
+ make
+
+}
+
+package() {
+ cd "$_builddir"
+
+ make DESTDIR=$pkgdir install
+
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/"$pkgname"/COPYING
+}
+
+md5sums="c0e2973f0dbd7655dcbb5e5979ddc199 httpup-0.4.0l.tar.gz
+a158568d4e6fe8cc5d5e3becc1508b31 10-getcwd.patch"
+sha256sums="005079b7d96b23e27dd645492e21f9f93a9a3ebd2ad061069bc038180c04a549 httpup-0.4.0l.tar.gz
+0f6ae9ef93cc835631dae836d3040deaf2f435b8bad6c4b5ea60bce36683b9d2 10-getcwd.patch"
+sha512sums="8e4aab2abc0792de1c9274c2df5ff50e1362d18bcb94fb908e4c9b691de9bb557f39908be015ae436cf4335e54ac4536a7292a304eac4a39a1425d92e36a8fee httpup-0.4.0l.tar.gz
+ba184e443539ddc935041e9cfc075bc8fc16df17329bc626ce6489ae754cee31906fa6339601c2e58333f44ac67fbfdce12b0eff602f83a234c206bfe649f774 10-getcwd.patch"