aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/ideviceinstaller
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/ideviceinstaller
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/ideviceinstaller')
-rw-r--r--unmaintained/ideviceinstaller/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/unmaintained/ideviceinstaller/APKBUILD b/unmaintained/ideviceinstaller/APKBUILD
new file mode 100644
index 0000000000..48a81cf32f
--- /dev/null
+++ b/unmaintained/ideviceinstaller/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=ideviceinstaller
+pkgver=1.1.0
+pkgrel=0
+pkgdesc="Manage Applications of an iPhone or iPod Touch"
+url="http://www.libimobiledevice.org/"
+arch="all"
+license="LGPL2.1"
+depends=""
+depends_dev=""
+makedepends="$depends_dev libimobiledevice-dev libzip-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://www.libimobiledevice.org/downloads/$pkgname-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ sed -i -e 's:-Werror -g::' configure || return 1
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="20bd74111c1e8bf7ce393f8f0919263c ideviceinstaller-1.1.0.tar.bz2"
+sha256sums="0821b8d3ca6153d9bf82ceba2706f7bd0e3f07b90a138d79c2448e42362e2f53 ideviceinstaller-1.1.0.tar.bz2"
+sha512sums="8bf5dc30b8fa2f0c171ec3705db8d8d143d2520b2875fc05d9d325bd4f1ffdf29230557e57f3e824654ab3bb71bbaf9019aa573d4b1cce29a9c75bf15024d623 ideviceinstaller-1.1.0.tar.bz2"