aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/ioping
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/ioping
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/ioping')
-rw-r--r--unmaintained/ioping/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/unmaintained/ioping/APKBUILD b/unmaintained/ioping/APKBUILD
new file mode 100644
index 0000000000..12b6df70be
--- /dev/null
+++ b/unmaintained/ioping/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=ioping
+pkgver=0.7
+pkgrel=1
+pkgdesc="A simple disk i/o latency measurement tool"
+url="http://code.google.com/p/ioping"
+arch="all"
+license="GPL3+"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://ioping.googlecode.com/files/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" PREFIX="/usr" install || return 1
+}
+
+md5sums="5fea9fb35c38902e0c1fcb7ffe203931 ioping-0.7.tar.gz"
+sha256sums="234e28eeb256e77756a077604b48d59f206a5288c3da6f207629e783f54b13b0 ioping-0.7.tar.gz"
+sha512sums="0f7140e6cac1d87f54c2b20323ec691cf0e54f246497e38cb03b1161943f4f872536f26fc6a30f304a375c192af7dfce67f03083f93a78c33c1cd0cd40787e74 ioping-0.7.tar.gz"