aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/jhead
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/jhead
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/jhead')
-rw-r--r--unmaintained/jhead/APKBUILD40
-rw-r--r--unmaintained/jhead/makefile-destdir.patch17
2 files changed, 57 insertions, 0 deletions
diff --git a/unmaintained/jhead/APKBUILD b/unmaintained/jhead/APKBUILD
new file mode 100644
index 0000000000..8e8aea3e8f
--- /dev/null
+++ b/unmaintained/jhead/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=jhead
+pkgver=2.93
+pkgrel=0
+pkgdesc="An Exif jpeg header manipulation tool"
+url="http://www.sentex.net/~mwandel/jhead/"
+arch="all"
+license="BSD"
+depends=""
+depends_dev=""
+makedepends=""
+install=""
+subpackages="$pkgname-doc"
+source="http://www.sentex.net/~mwandel/$pkgname/$pkgname-$pkgver.tar.gz
+ makefile-destdir.patch"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="23ac51b4aea2df663d684744e282eb7d jhead-2.93.tar.gz
+c0daea2a99f121ea84adb2fce47e0a4e makefile-destdir.patch"
diff --git a/unmaintained/jhead/makefile-destdir.patch b/unmaintained/jhead/makefile-destdir.patch
new file mode 100644
index 0000000000..d9c5b1a0b9
--- /dev/null
+++ b/unmaintained/jhead/makefile-destdir.patch
@@ -0,0 +1,17 @@
+--- jhead-2.93/makefile
++++ jhead-2.93/makefile.new
+@@ -4,6 +4,7 @@
+ OBJ=.
+ SRC=.
+ CFLAGS= -O3 -Wall
++prefix= /usr
+
+ all: jhead
+
+@@ -20,4 +21,5 @@
+ rm -f $(objs) jhead
+
+ install:
+- cp jhead ${DESTDIR}/usr/local/bin/
++ install -Dp -m 0755 jhead $(DESTDIR)$(prefix)/bin/jhead
++ install -m644 -D jhead.1 $(DESTDIR)$(prefix)/share/man/man1/jhead.1