aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/libdbusmenu-qt
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/libdbusmenu-qt
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/libdbusmenu-qt')
-rw-r--r--unmaintained/libdbusmenu-qt/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/unmaintained/libdbusmenu-qt/APKBUILD b/unmaintained/libdbusmenu-qt/APKBUILD
new file mode 100644
index 0000000000..1b6bc5daac
--- /dev/null
+++ b/unmaintained/libdbusmenu-qt/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer:
+pkgname=libdbusmenu-qt
+pkgver=0.8.2
+pkgrel=0
+pkgdesc="library to export QMenu over DBusMenu protocol"
+url="http://people.canonical.com/~agateau/dbusmenu/index.html"
+arch="all"
+license="LGPL"
+depends=
+depends_dev="qt-dev"
+makedepends="$depends_dev cmake automoc4 doxygen"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://launchpad.net/libdbusmenu-qt/trunk/$pkgver/+download/libdbusmenu-qt-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/libdbusmenu-qt-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ mkdir -p "$_builddir"/build
+}
+
+build() {
+ cd "$_builddir"/build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ "$_builddir" || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"/build
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="88be2548e00acf988c66ed3a35844f64 libdbusmenu-qt-0.8.2.tar.bz2"