aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/libecap
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/libecap
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/libecap')
-rw-r--r--unmaintained/libecap/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/unmaintained/libecap/APKBUILD b/unmaintained/libecap/APKBUILD
new file mode 100644
index 0000000000..4bf2dab0d0
--- /dev/null
+++ b/unmaintained/libecap/APKBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Roger Newman <roger.newman@riseup.net>
+pkgname=libecap
+pkgver=0.2.0
+pkgrel=0
+pkgdesc="eCAP allows an HTTP proxy or an ICAP server, to outsource content analysis and adaptation to a loadable module"
+url="http://www.e-cap.org/"
+arch="all"
+license="BSD"
+depends=""
+subpackages="$pkgname-dev"
+source="http://www.measurement-factory.com/tmp/ecap/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ update_config_sub || return 1
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --libdir=/lib \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make install \
+ libdir=/usr/lib \
+ pkgconfigdir="/usr/lib/pkgconfig" \
+ DESTDIR="$pkgdir" || return 1
+
+}
+
+md5sums="e65a855f4fbb0f3136af7fe28249e883 libecap-0.2.0.tar.gz"
+sha256sums="19e195d60cf67ec3b49fe4d109823d753546b5da115230499ad1a9cb65ca92d2 libecap-0.2.0.tar.gz"
+sha512sums="5d39444ec79846b14a7f4292e51bb880befd2cbf581b257d5087517cfae1dce55e4439a90c08e0b8f5b3e8b2431dde8c6fab771c826489024f17625cfc8c777e libecap-0.2.0.tar.gz"