aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/libgflags
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/libgflags
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/libgflags')
-rw-r--r--unmaintained/libgflags/APKBUILD64
1 files changed, 64 insertions, 0 deletions
diff --git a/unmaintained/libgflags/APKBUILD b/unmaintained/libgflags/APKBUILD
new file mode 100644
index 0000000000..a1f4f73dfb
--- /dev/null
+++ b/unmaintained/libgflags/APKBUILD
@@ -0,0 +1,64 @@
+# Contributor: David Huffman <storedbox@outlook.com>
+# Maintainer: David Huffman <storedbox@outlook.com>
+pkgname=libgflags
+pkgver=2.1.2
+_srcname=gflags-$pkgver
+pkgrel=0
+pkgdesc="A C++ library that implements commandline flags processing"
+url="https://gflags.github.io/gflags"
+arch="all"
+license="BSD"
+depends=""
+depends_dev=""
+makedepends="$depends_dev cmake"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-bash-completion:bashcomp"
+source="https://github.com/gflags/gflags/archive/v$pkgver/$_srcname.tar.gz"
+
+_builddir="$srcdir/$_srcname"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ cmake -Wno-dev \
+ -DBUILD_gflags_nothreads_LIB=OFF \
+ -DBUILD_SHARED_LIBS=ON \
+ -DBUILD_STATIC_LIBS=ON \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_SKIP_RPATH=ON \
+ -DCMAKE_VERBOSE_MAKEFILE=ON \
+ || return 1
+ make || return 1
+}
+
+package() {
+ local docdir="$pkgdir/usr/share/doc/$pkgname-$pkgver"
+ mkdir -p "$docdir" || return 1
+
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ cp AUTHORS.txt ChangeLog.txt COPYING.txt "$docdir"
+ cp -r doc "$docdir/html"
+}
+
+bashcomp() {
+ depends=""
+ pkgdesc="Bash completion for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+ arch="noarch"
+
+ install -Dm644 "$pkgdir/usr/bin/gflags_completions.sh" \
+ "$subpkgdir/usr/share/bash-completion/completions/gflags"
+}
+
+md5sums="ac432de923f9de1e9780b5254884599f gflags-2.1.2.tar.gz"
+sha256sums="d8331bd0f7367c8afd5fcb5f5e85e96868a00fd24b7276fa5fcee1e5575c2662 gflags-2.1.2.tar.gz"
+sha512sums="f636023c1150e4d536d2d472e40d643ff0b02d3c96d8cb7f31544df23e6255fa6c4fd927ef94a3660c250d3faeae7d8d78519fc5e856749a577347a78d9d9ab5 gflags-2.1.2.tar.gz"