aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/libgusb
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/libgusb
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/libgusb')
-rw-r--r--unmaintained/libgusb/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/unmaintained/libgusb/APKBUILD b/unmaintained/libgusb/APKBUILD
new file mode 100644
index 0000000000..226f84b860
--- /dev/null
+++ b/unmaintained/libgusb/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=libgusb
+pkgver=0.2.7
+pkgrel=0
+pkgdesc="GLib wrapper around libusb"
+url="https://gitorious.org/gusb/"
+arch="all"
+license="LGPL"
+depends=""
+depends_dev="eudev-dev libusb-dev glib-dev gobject-introspection-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://people.freedesktop.org/~hughsient/releases/libgusb-$pkgver.tar.xz"
+
+_builddir="$srcdir"/libgusb-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="74d6bd12ef8662fccd27fe33f2839375 libgusb-0.2.7.tar.xz"
+sha256sums="0be9578f7875cecb6c163ad47eb39bc6bf497e501b08986c0d384748a054c3ee libgusb-0.2.7.tar.xz"
+sha512sums="9210ddc95458c452fa32c8e11849c6f44e24680485aafe93887a52266c8253e495e5f0584f25e3e67051bb00247d6b658cd2ff3f6a4da167a113974d8fefd5ac libgusb-0.2.7.tar.xz"