aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/liblrdf
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/liblrdf
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/liblrdf')
-rw-r--r--unmaintained/liblrdf/APKBUILD68
1 files changed, 68 insertions, 0 deletions
diff --git a/unmaintained/liblrdf/APKBUILD b/unmaintained/liblrdf/APKBUILD
new file mode 100644
index 0000000000..39d004044c
--- /dev/null
+++ b/unmaintained/liblrdf/APKBUILD
@@ -0,0 +1,68 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=liblrdf
+pkgver=0.5.0
+pkgrel=0
+pkgdesc="Library for manipulating RDF files describing LADSPA plugins"
+url="https://github.com/swh/LRDF"
+arch="all"
+license="GPLv2+"
+depends=""
+depends_dev="raptor2-dev openssl-dev"
+makedepends="$depends_dev autoconf automake libtool"
+install=""
+subpackages="$pkgname-dev"
+source="http://dev.alpinelinux.org/archive/liblrdf/liblrdf-$pkgver.tar.gz"
+
+_builddir="$srcdir"/liblrdf-$pkgver
+
+# How to create archive from git:
+#
+# abuild snapshot
+#
+
+_gitrepo=LRDF.git
+_giturl="git://github.com/swh/$_gitrepo"
+_gittag=$pkgver
+
+snapshot() {
+ local _tarball=$pkgname-$pkgver.tar.gz
+ msg "Creating $_tarball.."
+ mkdir -p "$srcdir"
+ cd "${SRCDEST:-$srcdir}"
+ if ! [ -d "$_gitrepo" ]; then
+ git clone --bare $_giturl || return 1
+ else
+ git --git-dir=$_gitrepo fetch || return 1
+ fi
+
+ git --git-dir=$_gitrepo archive --prefix=$pkgname-$pkgver/ \
+ -o "$SRCDEST"/$_tarball $_gittag || return 1
+
+ msg "Uploading $_tarball"
+ scp "$SRCDEST"/$_tarball dev.alpinelinux.org:/archive/$pkgname/
+}
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./autogen.sh --prefix=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR="$pkgdir" || return 1
+}
+
+md5sums="9acf9143da25f2e0c46d24758371ff4b liblrdf-0.5.0.tar.gz"