aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/libnatspec
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/libnatspec
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/libnatspec')
-rw-r--r--unmaintained/libnatspec/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/unmaintained/libnatspec/APKBUILD b/unmaintained/libnatspec/APKBUILD
new file mode 100644
index 0000000000..d337a285b8
--- /dev/null
+++ b/unmaintained/libnatspec/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
+# Maintainer: Valery Kartel <valery.kartel@gmail.com>
+pkgname=libnatspec
+pkgver=0.3.0
+pkgrel=0
+pkgdesc="Library for national and language-specific issues"
+url="http://natspec.sourceforge.net"
+arch="all"
+license="LGPLv2"
+depends=""
+depends_dev="popt-dev"
+makedepends="autoconf automake libtool $depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
+source="http://downloads.sourceforge.net/project/natspec/natspec/0.3.0/$pkgname-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ autoreconf --install --force || return 1
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+tools() {
+ pkgdesc="$pkgdesc (tools)"
+ install -d "$subpkgdir"/usr || return 1
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr || return 1
+}
+md5sums="1bacec86f8688415a821a6ffae55532e libnatspec-0.3.0.tar.bz2"
+sha256sums="678db5f2e25be3e79183ecc9ff6b19fb66775bcb6c3c962ba7716bc4a8ecce71 libnatspec-0.3.0.tar.bz2"
+sha512sums="5c04358d20be5b6ffc7038bddd4514c4b5b4e9940fb6247070b832da9d059b31fd1306cf29f54e4a1b8be1d909176bd72e6ffa98e4b750840764f9b2c250d31c libnatspec-0.3.0.tar.bz2"