aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/libreswan
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/libreswan
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/libreswan')
-rw-r--r--unmaintained/libreswan/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/unmaintained/libreswan/APKBUILD b/unmaintained/libreswan/APKBUILD
new file mode 100644
index 0000000000..08c063aab0
--- /dev/null
+++ b/unmaintained/libreswan/APKBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+
+pkgname=libreswan
+pkgver=3.11
+pkgrel=0
+pkgdesc="IPsec implementation for Linux"
+url="https://libreswan.org"
+arch="all"
+license="GPLv2"
+depends="nss-tools iproute2"
+depends_dev="gmp-dev linux-pam-dev nss-dev unbound-dev libcap-ng-dev curl-dev nspr-dev"
+makedepends="$depends_dev bison flex coreutils bash"
+subpackages="$pkgname-doc"
+source="https://download.libreswan.org/libreswan-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make INC_RCDEFAULT=/etc/init.d \
+ INC_USRLOCAL=/usr \
+ FINALBINDIR=/usr/libexec/ipsec \
+ FINALLIBEXECDIR=/usr/libexec/ipsec \
+ programs || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make INC_MANDIR=share/man \
+ INC_RCDEFAULT=/etc/init.d \
+ INC_USRLOCAL=/usr \
+ DESTDIR="$pkgdir" \
+ INSTCONFFLAGS=-m644 \
+ FINALBINDIR=/usr/libexec/ipsec \
+ FINALLIBEXECDIR=/usr/libexec/ipsec \
+ install || return 1
+}
+md5sums="d8ffd012eb6933ff0f069334a85f81e1 libreswan-3.11.tar.gz"
+sha256sums="f2837f0ab380671844359fca397357e3045137ba31fabcef5abdb1d613939fc2 libreswan-3.11.tar.gz"
+sha512sums="40b91f05ca1156e33a3d6e2ee2932a65936392ae762b64bd20639bbb9a63269ae24d349f377d8b77743c84fbdfe0290bf581aa17e8634777147a5642995a1c7c libreswan-3.11.tar.gz"