aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/libsrs2/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/libsrs2/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/libsrs2/APKBUILD')
-rw-r--r--unmaintained/libsrs2/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/unmaintained/libsrs2/APKBUILD b/unmaintained/libsrs2/APKBUILD
new file mode 100644
index 0000000000..c953f30203
--- /dev/null
+++ b/unmaintained/libsrs2/APKBUILD
@@ -0,0 +1,52 @@
+#Contributor: Valery Kartel <valery.kartel@gmail.com>
+# Maintainer: Valery Kartel <valery.kartel@gmail.com>
+pkgname=libsrs2
+pkgver=1.0.18
+pkgrel=0
+pkgdesc="Sender Rewriting Scheme library, a part of the SPF/SRS protocol pair"
+url="http://www.libsrs2.org"
+arch="all"
+license="LGPL2.1 BSD-2"
+subpackages="$pkgname-dev $pkgname-tools"
+makedepends=
+depends=
+source="http://www.libsrs2.org/srs/$pkgname-$pkgver.tar.gz
+ "
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --disable-static \
+ --with-pic \
+ || return 1
+ make -j1 || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 DESTDIR="$pkgdir" install || return 1
+}
+
+tools() {
+ pkgdesc="SRS command-line utility"
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr
+}
+
+md5sums="2178b8cf587eb6e65d4b9753c4a6c67d libsrs2-1.0.18.tar.gz"
+sha256sums="9d1191b705d7587a5886736899001d04168392bbb6ed6345a057ade50943a492 libsrs2-1.0.18.tar.gz"
+sha512sums="b9c189caa227487e90566f65430345f09a3d545fc286a3eb0c445aee3a74905c1a9248ce78b36a7cfb6a2936f6cd1efbe99ba7b8df49a613a81c6435396f5422 libsrs2-1.0.18.tar.gz"