aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/libsyncml
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2014-10-28 11:36:31 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2014-10-28 11:36:31 +0100
commitaa5561707f2c655b077a82c9f25da63705f85bd8 (patch)
treec6bc8fd0b39aaea9708a276f1beba0e9ce05698c /unmaintained/libsyncml
parent1f3b0db9ba3341ea7e9ff25b459390cafc4b4eb0 (diff)
downloadaports-aa5561707f2c655b077a82c9f25da63705f85bd8.tar.bz2
aports-aa5561707f2c655b077a82c9f25da63705f85bd8.tar.xz
testing/libsyncml: unmaintained
Diffstat (limited to 'unmaintained/libsyncml')
-rw-r--r--unmaintained/libsyncml/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/unmaintained/libsyncml/APKBUILD b/unmaintained/libsyncml/APKBUILD
new file mode 100644
index 0000000000..550f4b40f4
--- /dev/null
+++ b/unmaintained/libsyncml/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libsyncml
+pkgver=0.5.4
+pkgrel=1
+pkgdesc="Implementation of the SyncML protocol"
+url="http://libsyncml.opensync.org/"
+arch="all"
+license="LGPL-2.1"
+depends=
+makedepends="glib-dev libxml2-dev libwbxml-dev openobex-dev bluez-dev cmake"
+install=
+subpackages="$pkgname-dev"
+source="http://downloads.sourceforge.net/libsyncml/libsyncml-$pkgver.tar.bz2"
+
+_srcdir="$srcdir"/$pkgname-$pkgver
+_builddir="$srcdir"/build
+
+prepare() {
+ mkdir -p "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr "$_srcdir"
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR="$pkgdir"
+}
+
+md5sums="b8ce1f222cccc12acdcd6807d65c1aea libsyncml-0.5.4.tar.bz2"