aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/libuniso
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/libuniso
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/libuniso')
-rw-r--r--unmaintained/libuniso/APKBUILD52
-rw-r--r--unmaintained/libuniso/musl-missing-typesh.patch10
2 files changed, 62 insertions, 0 deletions
diff --git a/unmaintained/libuniso/APKBUILD b/unmaintained/libuniso/APKBUILD
new file mode 100644
index 0000000000..70ad9bc326
--- /dev/null
+++ b/unmaintained/libuniso/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libuniso
+pkgver=0.1
+pkgrel=1
+pkgdesc="Library to unpack files from CDROM (ISO-9660) images"
+url="http://code.google.com/p/libuniso"
+arch="all"
+license="LGPLv2.1"
+depends=""
+depends_dev=""
+makedepends="lua-dev"
+install=""
+subpackages="$pkgname-dev lua-uniso:_lua"
+source="http://libuniso.googlecode.com/files/libuniso-$pkgver.tar.bz2
+ musl-missing-typesh.patch"
+
+_builddir="$srcdir"/libuniso-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ echo ENABLE_LUA=yes > config.mk
+ echo ENABLE_SHARED=yes >> config.mk
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+_lua() {
+ pkgdesc="Lua module for libuniso"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/lua "$subpkgdir"/usr/lib/
+}
+
+md5sums="9c1e65ceecce5786ff33c5dd82bea897 libuniso-0.1.tar.bz2
+e0948a860bbc3d93bfa7ebf25e0440ec musl-missing-typesh.patch"
+sha256sums="fc6a80200d6f8b20a99cd888cbcb0d55c8b45c5a3a6b540b99bbedb54a0248ad libuniso-0.1.tar.bz2
+9840e7c7a2d0459e8f7652d901b172de4fdcf6de46461b7c56fac127b3dda142 musl-missing-typesh.patch"
+sha512sums="dea27691b3e53bd6d7ff4c3530cb0e3d8c353bf03cbd7057910f37aa478fc95d66d4300a4dfa1c410957fafbce2d28e0b39a4e34928f6b0a562d3d6043e0f8e6 libuniso-0.1.tar.bz2
+56db43a674afc969f742524680eb02ae9685818022d4310ed8d1a6c727f5a185ccee9ed6553140b91403053311dd89a30d00602d4ee9d29bb3a96406d0462c95 musl-missing-typesh.patch"
diff --git a/unmaintained/libuniso/musl-missing-typesh.patch b/unmaintained/libuniso/musl-missing-typesh.patch
new file mode 100644
index 0000000000..098cbc46ce
--- /dev/null
+++ b/unmaintained/libuniso/musl-missing-typesh.patch
@@ -0,0 +1,10 @@
+--- a/libuniso.c.orig
++++ b/libuniso.c
+@@ -30,6 +30,7 @@
+ #include <string.h>
+ #include <endian.h>
+ #include <sys/stat.h>
++#include <sys/types.h>
+
+ #include "uniso.h"
+