aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/lrzsz
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/lrzsz
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/lrzsz')
-rw-r--r--unmaintained/lrzsz/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/unmaintained/lrzsz/APKBUILD b/unmaintained/lrzsz/APKBUILD
new file mode 100644
index 0000000000..782c7a2f9d
--- /dev/null
+++ b/unmaintained/lrzsz/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=lrzsz
+pkgver=0.12.20
+pkgrel=0
+pkgdesc="xmodem, ymodem and zmodem file transfer protocols"
+url="http://www.ohse.de/uwe/software/lrzsz.html"
+arch="all"
+license="GPL2"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://www.ohse.de/uwe/releases/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+
+ # make install tries to remove stuff from /usr/bin
+ sed -i -e '/rm -f $(bindir)/d' src/Makefile.in
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --program-transform-name=s/l//
+ make -j1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 DESTDIR="$pkgdir" install
+}
+
+md5sums="b5ce6a74abc9b9eb2af94dffdfd372a4 lrzsz-0.12.20.tar.gz"