aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/lua-ejdb
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/lua-ejdb
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/lua-ejdb')
-rw-r--r--unmaintained/lua-ejdb/APKBUILD49
-rw-r--r--unmaintained/lua-ejdb/unbundle-inspect.patch17
2 files changed, 66 insertions, 0 deletions
diff --git a/unmaintained/lua-ejdb/APKBUILD b/unmaintained/lua-ejdb/APKBUILD
new file mode 100644
index 0000000000..a846c9337f
--- /dev/null
+++ b/unmaintained/lua-ejdb/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=lua-ejdb
+pkgver=1.2.3
+pkgrel=0
+pkgdesc="EJDB Lua binding for Lua 5.1"
+url="https://github.com/Softmotions/ejdb-lua"
+arch="all"
+license="GPLv2"
+depends="lua5.1-inspect"
+depends_dev=""
+makedepends="$depends_dev lua5.1-dev ejdb-dev"
+install=""
+subpackages=""
+source="http://dev.alpinelinux.org/archive/lua-ejdb/lua-ejdb-$pkgver.tar.gz
+ unbundle-inspect.patch"
+
+_builddir="$srcdir/ejdb-lua-master"
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ${CC:-gcc} $CFLAGS $(pkg-config --cflags libejdb) -shared -fPIC -o \
+ luaejdb.so luaejdb.c luabson.c $(pkg-config --libs libejdb)
+}
+
+package() {
+ cd "$_builddir"
+ install -Dm644 luaejdb.so \
+ "$pkgdir"/usr/lib/lua/5.1/luaejdb.so || return 1
+ install -Dm644 ejdb.lua \
+ "$pkgdir"/usr/share/lua/5.1/ejdb.lua || return 1
+}
+
+md5sums="d2295fd8aa3e5bc1188ee261a8645a66 lua-ejdb-1.2.3.tar.gz
+6ffcbd12d1e97b6dc53b29e1f349396b unbundle-inspect.patch"
+sha256sums="75866565110c0c7e3566794b01a79394179b24685fd89c28f7ca93e651435404 lua-ejdb-1.2.3.tar.gz
+da4f1d9b0f9825ba5a832c572d3a3cd5a3e1a45cd91dc4628bdd1f36c4caf8f9 unbundle-inspect.patch"
+sha512sums="d1fc7f2051fdf95a366f140d0f17e4552398138b25f580292bd1cbe2c4d1a373297fb003f103e5703bb296290ca9ad748175cff32ee3c5e1473fd6d00b23f524 lua-ejdb-1.2.3.tar.gz
+de4a79222358e368e740c3c41208ea6562212093e0e214153f137bd1a82ed99623cdc3037094dee713d75ea680a4a43f1c9318fcb4288c78ca4926acff4df386 unbundle-inspect.patch"
diff --git a/unmaintained/lua-ejdb/unbundle-inspect.patch b/unmaintained/lua-ejdb/unbundle-inspect.patch
new file mode 100644
index 0000000000..a2694a004f
--- /dev/null
+++ b/unmaintained/lua-ejdb/unbundle-inspect.patch
@@ -0,0 +1,17 @@
+--- ./ejdb.lua.orig
++++ ./ejdb.lua
+@@ -1,6 +1,6 @@
+ local luaejdb = require("luaejdb")
+ assert(type(luaejdb) == "table")
+-local inspect = require("ejdb.inspect")
++local inspect = require("inspect")
+
+ -- ------------ Misc -----------------------
+
+@@ -532,4 +532,4 @@
+ })
+ luaejdb.Q = luaejdb.B -- Name variations
+
+-return luaejdb;
+\ No newline at end of file
++return luaejdb;