aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/lua-ljsyscall
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/lua-ljsyscall
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/lua-ljsyscall')
-rw-r--r--unmaintained/lua-ljsyscall/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/unmaintained/lua-ljsyscall/APKBUILD b/unmaintained/lua-ljsyscall/APKBUILD
new file mode 100644
index 0000000000..e4c5f446d6
--- /dev/null
+++ b/unmaintained/lua-ljsyscall/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Michael Zuo <muh.muhten@gmail.com>
+# Maintainer: Michael Zuo <muh.muhten@gmail.com>
+pkgname=lua-ljsyscall
+pkgver=0.11
+pkgrel=0
+pkgdesc="LuaJIT Unix syscall FFI"
+url="http://www.myriabit.com/ljsyscall/"
+arch="all"
+license="MIT"
+depends=""
+makedepends="luajit"
+source="${pkgname#lua-}-$pkgver.tar.gz::https://github.com/justincormack/ljsyscall/archive/v$pkgver.tar.gz"
+options="!archcheck"
+
+_builddir="$srcdir/${pkgname#lua-}-$pkgver"
+build() {
+ cd "$_builddir"
+ find syscall/* -maxdepth 0 \
+ -type d \
+ -not -name linux \
+ -not -name shared \
+ -exec rm -r {} +
+ # we don't target mips, so no special case
+ find -H syscall/linux/* -maxdepth 0 \
+ -type d \
+ -not -name "`luajit -e 'print(jit.arch)'`" \
+ -exec rm -r {} +
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir/usr/share/lua/5.1"
+ cp -a syscall.lua syscall "$pkgdir/usr/share/lua/5.1"
+}
+
+md5sums="bd4a13b7bbb3b21cdfe18d7be4d53483 ljsyscall-0.11.tar.gz"
+sha256sums="2353f8e512db4b19f86b499cb12396e5915a41f000a80c61435297a72330c6f3 ljsyscall-0.11.tar.gz"
+sha512sums="0a78dc6601a0192011428447b5ab18d700ca005720d7e7c9f51fa7f38dc8f8410702da65feb72b7aa161d3934e62b5d2be3d7f345ad19e0d5356b1aa3cef3d7e ljsyscall-0.11.tar.gz"