aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/lua-zip/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/lua-zip/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/lua-zip/APKBUILD')
-rw-r--r--unmaintained/lua-zip/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/unmaintained/lua-zip/APKBUILD b/unmaintained/lua-zip/APKBUILD
new file mode 100644
index 0000000000..ca5a389cd8
--- /dev/null
+++ b/unmaintained/lua-zip/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Mika Havela <mika.havela@gmail.com>
+# Maintainer: Mika Havela <mika.havela@gmail.com>
+pkgname=lua-zip
+pkgver="1.2.3"
+pkgrel=0
+pkgdesc="Lua extension library used to read files stored inside zip files"
+url="http://luaforge.net/projects/luazip/"
+arch="all"
+license="MIT"
+depends="lua"
+makedepends="lua-dev zziplib-dev"
+install=""
+subpackages=""
+source="http://archive.ubuntu.com/ubuntu/pool/universe/l/lua-zip/lua-zip_${pkgver}.orig.tar.gz"
+
+_builddir="$srcdir/luazip-$pkgver"
+prepare() {
+ cd "$_builddir"
+ sed -i -e '/LUA_VERSION_NUM/d' config
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make CFLAGS="$CFLAGS" CC="${CC:-gcc}"
+}
+
+package() {
+ cd "$_builddir"
+ local _lua_libdir="$(pkg-config --variable=INSTALL_CMOD lua)"
+ make LUA_LIBDIR="${pkgdir}${_lua_libdir}" \
+ install || return 1
+}
+
+md5sums="8129ba93a8df6ebd324fee9adca23fae lua-zip_1.2.3.orig.tar.gz"