aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/lua5.2-xctrl
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/lua5.2-xctrl
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/lua5.2-xctrl')
-rw-r--r--unmaintained/lua5.2-xctrl/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/unmaintained/lua5.2-xctrl/APKBUILD b/unmaintained/lua5.2-xctrl/APKBUILD
new file mode 100644
index 0000000000..39c608acc2
--- /dev/null
+++ b/unmaintained/lua5.2-xctrl/APKBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+_luaver=5.2
+pkgname=lua$_luaver-xctrl
+pkgver=2013.06.20
+_x=${pkgver%%.*}
+_y=${pkgver%.*}
+_y=${_y#*.}
+_z=${pkgver##*.}
+_ver=${_x}-${_y}-${_z}
+pkgrel=0
+pkgdesc="Lua $_luaver module to query and manipulate X11 window managers"
+url="http://code.google.com/p/xctrl/"
+arch="all"
+license="GPL2"
+depends=
+makedepends="lua$_luaver-dev libx11-dev libxmu-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://xctrl.googlecode.com/files/xctrl-$_ver.tar.gz"
+
+_builddir="$srcdir"/xctrl-$_ver
+_lua_libdir=/usr/lib/lua/$_luaver
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ export EXTRA_CFLAGS="-fPIC $( pkg-config lua$_luaver --cflags )"
+ make -C src LUA=lua5.2 || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -d "$pkgdir"/$_lua_libdir "$pkgdir"/usr/share/doc/$pkgname
+ install src/xctrl.so "$pkgdir"/$_lua_libdir/xctrl.so
+ install doc/lxctrl.html "$pkgdir"/usr/share/doc/$pkgname/lxctrl.html
+}
+
+md5sums="789f39228436e4c806911c6cbaae444a xctrl-2013-06-20.tar.gz"
+sha256sums="9089ff10f5396e0a74b3f80c03d8f54395219d72f6ea0084e2858d7195ececbf xctrl-2013-06-20.tar.gz"
+sha512sums="ebfbd3b13c0d5432c71afa6bc70984c794242204c9ce9eaaf391092f7cf5c99dbe0c66335bb9c97413d304f1f77529bddf6a0f37fb10eeab5fbcb7d75dc92d48 xctrl-2013-06-20.tar.gz"