aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/mac-robber
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/mac-robber
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/mac-robber')
-rw-r--r--unmaintained/mac-robber/APKBUILD45
-rw-r--r--unmaintained/mac-robber/include-paramh.patch10
2 files changed, 55 insertions, 0 deletions
diff --git a/unmaintained/mac-robber/APKBUILD b/unmaintained/mac-robber/APKBUILD
new file mode 100644
index 0000000000..b8e9c864dc
--- /dev/null
+++ b/unmaintained/mac-robber/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=mac-robber
+pkgver=1.02
+pkgrel=0
+pkgdesc="Tool to create a timeline of file activity for mounted file systems"
+url="http://sourceforge.net/projects/mac-robber/"
+arch="all"
+license="GPL2+"
+depends=""
+depends_dev=""
+makedepends=""
+install=""
+subpackages=""
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ include-paramh.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -Dpm 0755 $pkgname "$pkgdir"/usr/bin/$pkgname || return 1
+}
+
+md5sums="6d6d99aa882a46b2bc5231d195fdb595 mac-robber-1.02.tar.gz
+c2b45c05cd35ef2fa59b13124fe908fa include-paramh.patch"
+sha256sums="5895d332ec8d87e15f21441c61545b7f68830a2ee2c967d381773bd08504806d mac-robber-1.02.tar.gz
+f69e14c2e0f7431d16b711b719a5112ab3797520110fcf61b1c8fa1c53816bb1 include-paramh.patch"
+sha512sums="5330f766eb08aa766ca3f430684e0a40ecf29b7230a582c30a36bbaaa481d52c2a8519fa04e82762f09259ada9e77466c1430aebdff22615a511d519916d54a7 mac-robber-1.02.tar.gz
+4fc0ac48132d2dfbf150fb297d6a740d867c8308215970ac9bce433961cac3d2e32ca57060e4a5f948598f832cdafe931583993df27e9fd4d24139977311cf20 include-paramh.patch"
diff --git a/unmaintained/mac-robber/include-paramh.patch b/unmaintained/mac-robber/include-paramh.patch
new file mode 100644
index 0000000000..1bf20fda5d
--- /dev/null
+++ b/unmaintained/mac-robber/include-paramh.patch
@@ -0,0 +1,10 @@
+--- a/mac-robber.c.orig
++++ b/mac-robber.c
+@@ -44,6 +44,7 @@
+
+ #include <sys/types.h>
+ #include <sys/stat.h>
++#include <sys/param.h>
+ #include <dirent.h>
+ #include <stdio.h>
+ #include <stdlib.h>