aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/makepasswd/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/makepasswd/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/makepasswd/APKBUILD')
-rw-r--r--unmaintained/makepasswd/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/unmaintained/makepasswd/APKBUILD b/unmaintained/makepasswd/APKBUILD
new file mode 100644
index 0000000000..211bbd9e34
--- /dev/null
+++ b/unmaintained/makepasswd/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=makepasswd
+pkgver=0.5.2
+pkgrel=0
+pkgdesc="Generates (pseudo-)random passwords of a desired length"
+url="http://people.defora.org/~khorben/projects/makepasswd/"
+arch="all"
+license="GPL3"
+depends=""
+depends_dev=""
+makedepends="$depends_dev libxslt docbook-xsl"
+install=""
+subpackages="$pkgname-doc"
+source="http://ftp.defora.org/pub/projects/makepasswd/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+ pushd doc
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -D -p -m 755 src/makepasswd "$pkgdir"/usr/bin/makepasswd
+ install -D -p -m 644 doc/makepasswd.1 \
+ "$pkgdir"/usr/share/man/man1/$pkgname.1 || return 1
+}
+
+md5sums="cf9cc172c57bf8443514e69ad72ec412 makepasswd-0.5.2.tar.gz"
+sha256sums="8a08e40972ab6db3c57e7e5040d4ca9f7be792d3405afd54de136ebbb7039891 makepasswd-0.5.2.tar.gz"
+sha512sums="24bf03bb9170bb96e2262b889e6ba789618a81e132895d0e35615d70d35b6ac36d8001d49f3bc688e062d922049e07ea40528ee4b315b2f3241df6bec5d33633 makepasswd-0.5.2.tar.gz"