aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/mlocate/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-08-22 17:02:22 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-08-22 17:03:03 +0200
commit1e1cd44e4d49bd52687d4a044c56b90dfd2916be (patch)
treebea775b65969e0d8cdb8daf2a6799acbb5394d3a /unmaintained/mlocate/APKBUILD
parentb55612c5aca4ae839bea079464d76a107003ef67 (diff)
downloadaports-1e1cd44e4d49bd52687d4a044c56b90dfd2916be.tar.bz2
aports-1e1cd44e4d49bd52687d4a044c56b90dfd2916be.tar.xz
testing/mlocate: move to unmaintained (doesn't work)
This package doesn't work for a long time and I don't know how to fix it.
Diffstat (limited to 'unmaintained/mlocate/APKBUILD')
-rw-r--r--unmaintained/mlocate/APKBUILD58
1 files changed, 58 insertions, 0 deletions
diff --git a/unmaintained/mlocate/APKBUILD b/unmaintained/mlocate/APKBUILD
new file mode 100644
index 0000000000..f71e91f80d
--- /dev/null
+++ b/unmaintained/mlocate/APKBUILD
@@ -0,0 +1,58 @@
+# Contributor: Leslie P. Polzer <polzer@port-zero.com>
+# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+# Maintainer:
+
+pkgname=mlocate
+pkgver=0.26
+pkgrel=4
+pkgdesc='A utility to index and quickly search for files by name'
+url='https://fedorahosted.org/mlocate/'
+arch=''
+license='GPL'
+options='suid'
+pkggroups='locate'
+install="$pkgname.pre-install"
+makedepends=""
+subpackages="$pkgname-doc"
+source="https://fedorahosted.org/releases/m/l/mlocate/mlocate-$pkgver.tar.xz
+ updatedb.conf
+ updatedb.cron.daily"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ sed -i '/^groupname /s/mlocate/locate/' Makefile.in
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+
+ make DESTDIR="$pkgdir" install
+
+ ln -s locate "$pkgdir"/usr/bin/slocate
+
+ install -dm755 "$pkgdir"/var/lib
+
+ install -Dm644 "$srcdir"/updatedb.conf "$pkgdir"/etc/updatedb.conf
+ install -Dm744 "$srcdir"/updatedb.cron.daily \
+ "$pkgdir"/etc/periodic/daily/updatedb
+ rm -rf "${pkgdir}"/usr/lib
+}
+md5sums="539e6f86bf387358aa2b14d5f880e49a mlocate-0.26.tar.xz
+465315bfa3380a23fae9a383270cb2ec updatedb.conf
+cde5da81bebad2de556ef2e43d895e13 updatedb.cron.daily"
+sha256sums="3063df79fe198fb9618e180c54baf3105b33d88fe602ff2d8570aaf944f1263e mlocate-0.26.tar.xz
+2523ec44fc74eb112a21671aca7cd3f5967e349c6017f5c34591c82f85490e81 updatedb.conf
+fe70ce6b8771bc750d5200ab4cc5bd97b579eeec92f1939f5d777614a0736c3e updatedb.cron.daily"
+sha512sums="b1207047e30a551cba39e70812439b554def567ebe9b8b81fed6f26435bb575beafe4875a21cd72876eadd85da4e7bfc942eb28b17c430b537c351690364837f mlocate-0.26.tar.xz
+663ebf09348458a3c82ac83bf77de9d38a214bd91c73385b2ea7fb7eda5beaaa7ad1d7c66a8a017ef6a0d5295ff1778bedab9be60d9b3a5ac3fefe5f1593a5f5 updatedb.conf
+60551f1574a31650bc665901cac418366ba26dc8514fb82ca55c75d29a9617ce05bc77b2a14c724cd49c8375d8ad5c3e9ba4df4210ce1b6b37bb3a244dcdc84c updatedb.cron.daily"