aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/mpop
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/mpop
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/mpop')
-rw-r--r--unmaintained/mpop/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/unmaintained/mpop/APKBUILD b/unmaintained/mpop/APKBUILD
new file mode 100644
index 0000000000..cc26629f50
--- /dev/null
+++ b/unmaintained/mpop/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: z3bra <willy at mailoo dot org>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=mpop
+pkgver=1.2.2
+pkgrel=0
+pkgdesc="A small an fast POP3 client"
+url="http://$pkgname.sourceforge.net/"
+arch="all"
+license="GPL3"
+depends=""
+depends_dev="gnutls-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz"
+
+_builddir=$srcdir/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --with-ssl=gnutls \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="4ff3088fcbc94c70c66d6002435bfe9c mpop-1.2.2.tar.xz"
+sha256sums="d1e7d7d18147996cfc6195cdfb936ca51620cb841a7460043d8cc838ca48bfc3 mpop-1.2.2.tar.xz"
+sha512sums="5cb78ac088fa5da4e6c8f049510e0aab986b73f062b05169482adf6b14cb9abe04f93bd4672837c3b406880f86e4bbf6f5dd8c5b98b1bcad485ac43ea48ae7c7 mpop-1.2.2.tar.xz"