aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/ms-sys
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/ms-sys
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/ms-sys')
-rw-r--r--unmaintained/ms-sys/APKBUILD46
-rw-r--r--unmaintained/ms-sys/nls.patch32
2 files changed, 78 insertions, 0 deletions
diff --git a/unmaintained/ms-sys/APKBUILD b/unmaintained/ms-sys/APKBUILD
new file mode 100644
index 0000000000..86858917b7
--- /dev/null
+++ b/unmaintained/ms-sys/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=ms-sys
+pkgver=2.4.0
+pkgrel=0
+pkgdesc="A tool for creating Microsoft compatible boot records"
+url="http://ms-sys.sourceforge.net/"
+arch="all"
+license="GPL2+"
+depends=""
+depends_dev=""
+makedepends="$depends_dev linux-headers"
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/ms-sys/ms-sys-$pkgver.tar.gz
+ nls.patch"
+
+_builddir="$srcdir"/ms-sys-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make PREFIX=/usr NLS=no || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make PREFIX=/usr MANDIR=/usr/share/man DESTDIR="$pkgdir" NLS=no \
+ install || return 1
+ rm -rf "$pkgdir"/usr/share/locale
+}
+
+md5sums="6742dd1a058b1ce32cb991853d9d6bec ms-sys-2.4.0.tar.gz
+e99ecd149e6e83a60647dbb96409b949 nls.patch"
+sha256sums="afcfefb52350f632bbd4671c3f97df09e42a60d0de3e56d42682450c7ebf689e ms-sys-2.4.0.tar.gz
+0cde6bb2fbe958380b2cd058095da3b6da690d9462909a4acf867dab9e19d6e8 nls.patch"
+sha512sums="17e2496d2e4815180b9f33fa0f206953fb3484e01c115a2e67d110fb04d421be7e694a434d991a7518579eadb9dce4e907dbd849dbaf6fb506758c425faa14ec ms-sys-2.4.0.tar.gz
+02115f778a74cc8b048872d437745e1b9c272b3c3597dc180ffa9fd6a977bf97d0744bc18ebc4a2ce08942f2ec94a96cda2f85d36289140d53e32aa20f8b75ee nls.patch"
diff --git a/unmaintained/ms-sys/nls.patch b/unmaintained/ms-sys/nls.patch
new file mode 100644
index 0000000000..29c77a62c2
--- /dev/null
+++ b/unmaintained/ms-sys/nls.patch
@@ -0,0 +1,32 @@
+--- ./inc/nls.h.orig
++++ ./inc/nls.h
+@@ -1,11 +1,10 @@
+ #ifndef NLS_H
+ #define NLS_H
+
+-#include <libintl.h>
+-
+ #ifdef NO_LIBINTL_OR_GETTEXT
+ #define _(String) (String)
+ #else
++#include <libintl.h>
+ #define _(String) gettext(String)
+ #endif
+ #define gettext_noop(String) (String)
+--- ./Makefile.orig
++++ ./Makefile
+@@ -80,10 +80,14 @@
+
+ MAN_SRC = $(wildcard $(MAN)/*.*)
+
++ifeq ($(NLS),no)
++CFLAGS += -DNO_LIBINTL_OR_GETTEXT
++else
+ PO_FILES = $(filter-out $(MESSAGES),$(wildcard $(PO)/*.po))
+ MO_FILES = $(PO_FILES:$(PO)/%.po=$(MO)/%.mo)
+ LANGUAGES ?= $(PO_FILES:$(PO)/%.po=%)
+ NLS_FILES = $(LANGUAGES:%=$(DESTDIR)$(LOCALEDIR)/%/$(MESSDIR)/$(PACKAGE).mo)
++endif
+ MAN_FILES = $(foreach FILE, $(MAN_SRC), \
+ $(DESTDIR)$(MANDIR)/man$(subst .,,$(suffix $(FILE)))/$(FILE:$(MAN)/%=%))
+