aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/mytop
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/mytop
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/mytop')
-rw-r--r--unmaintained/mytop/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/unmaintained/mytop/APKBUILD b/unmaintained/mytop/APKBUILD
new file mode 100644
index 0000000000..22191b6cb1
--- /dev/null
+++ b/unmaintained/mytop/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=mytop
+pkgver=1.6
+pkgrel=0
+pkgdesc="A top clone for MySQL"
+url="http://jeremy.zawodny.com/mysql/mytop/"
+arch="noarch"
+license="GPL2"
+depends="perl perl-term-readkey perl-dbd-mysql"
+depends_dev=""
+makedepends="perl-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://jeremy.zawodny.com/mysql/mytop/${pkgname}-${pkgver}.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ sed -i 's#"long|!"#"long!"#' $pkgname || return 1
+}
+
+build() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make && make test || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="4127c3e486eb664fed60f40849372a9f mytop-1.6.tar.gz"