aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/nbtscan/nbtscan-1.5.1-makefile.patch
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/nbtscan/nbtscan-1.5.1-makefile.patch
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/nbtscan/nbtscan-1.5.1-makefile.patch')
-rw-r--r--unmaintained/nbtscan/nbtscan-1.5.1-makefile.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/unmaintained/nbtscan/nbtscan-1.5.1-makefile.patch b/unmaintained/nbtscan/nbtscan-1.5.1-makefile.patch
new file mode 100644
index 0000000000..300f2a6aef
--- /dev/null
+++ b/unmaintained/nbtscan/nbtscan-1.5.1-makefile.patch
@@ -0,0 +1,20 @@
+--- nbtscan-1.5.1a/Makefile.in.orig
++++ nbtscan-1.5.1a/Makefile.in
+@@ -5,6 +5,7 @@
+ OBJECTS=nbtscan.o statusq.o range.o list.o
+ DEFS=@DEFS@
+ TARGET=@TARGET@
++DESTDIR=
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+@@ -14,7 +15,8 @@
+ $(CC) $(CFLAGS) -o nbtscan $(OBJECTS) $(LIBS)
+
+ install:
+- $(INSTALL) $(TARGET) $(BINDIR)/$(TARGET)
++ mkdir -p $(DESTDIR)$(BINDIR)
++ $(INSTALL) $(TARGET) $(DESTDIR)$(BINDIR)/$(TARGET)
+
+ nbtscan.o: nbtscan.c statusq.h range.h list.h
+ $(CC) $(CFLAGS) $(DEFS) -c nbtscan.c