aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/ncmpcpp/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/ncmpcpp/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/ncmpcpp/APKBUILD')
-rw-r--r--unmaintained/ncmpcpp/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/unmaintained/ncmpcpp/APKBUILD b/unmaintained/ncmpcpp/APKBUILD
new file mode 100644
index 0000000000..e73ff8a400
--- /dev/null
+++ b/unmaintained/ncmpcpp/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=ncmpcpp
+pkgver=0.6.8
+pkgrel=2
+pkgdesc="An almost exact clone of ncmpc with some new features."
+url="http://ncmpcpp.rybczak.net/"
+arch="all"
+license="GPL2+"
+depends=""
+depends_dev=""
+makedepends="boost-dev readline-dev curl-dev libmpdclient-dev
+ taglib-dev ncurses-dev openssl-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://ncmpcpp.rybczak.net/stable/ncmpcpp-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build () {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --enable-unicode \
+ --enable-clock \
+ --with-taglib \
+ --with-curl \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="90b5b22a6365c17bc7d75c05d2117413 ncmpcpp-0.6.8.tar.bz2"
+sha256sums="ee81f3fdb2a4b670b5e2617f6489f154e69a552e68fc550b1e20ad85f526e692 ncmpcpp-0.6.8.tar.bz2"
+sha512sums="e474bd4122212c34d7043adf7b68aeaaa2e9b5a999840b7e8632d251bdab17f5314fca03bdf2b8eee5de2572d3e5c602d87a1f89889ab7c747321e4272f63ebc ncmpcpp-0.6.8.tar.bz2"