aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/netdiscover
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/netdiscover
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/netdiscover')
-rw-r--r--unmaintained/netdiscover/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/unmaintained/netdiscover/APKBUILD b/unmaintained/netdiscover/APKBUILD
new file mode 100644
index 0000000000..5a72b68bfc
--- /dev/null
+++ b/unmaintained/netdiscover/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=netdiscover
+pkgver=0.3
+pkgrel=1.beta6
+pkgdesc="A network address discovering tool"
+url="http://nixgeneration.com/~jaime/netdiscover/"
+arch="all"
+license="GPL2+"
+depends=""
+depends_dev=""
+makedepends="libnet-dev libpcap-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/netdiscover/netdiscover-$pkgver-beta6.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver-beta6
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -rf "$pkgdir"/usr/doc/
+}
+
+md5sums="0919227a91ecaeeb2443cff249417be2 netdiscover-0.3-beta6.tar.gz"
+sha256sums="19c367f823c49999e2c05c485cac0a5d5685d23c6b33deae1e957406571924db netdiscover-0.3-beta6.tar.gz"
+sha512sums="b8205322c34684642d52bf58f8fffa12a0dea387da713caf2935ba348c74b2e6cac717bf1626c9de816e45dce7c42b6b9584b5253351040af806f7ba262ce4d2 netdiscover-0.3-beta6.tar.gz"