aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/nwipe
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/nwipe
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/nwipe')
-rw-r--r--unmaintained/nwipe/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/unmaintained/nwipe/APKBUILD b/unmaintained/nwipe/APKBUILD
new file mode 100644
index 0000000000..bafead7251
--- /dev/null
+++ b/unmaintained/nwipe/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=nwipe
+pkgver=0.16
+pkgrel=0
+pkgdesc="Securely erase disks using a variety of recognized methods"
+url="http://nwipe.sourceforge.net"
+arch="all"
+license="GPL2"
+depends=""
+depends_dev=""
+makedepends="parted-dev ncurses-dev autoconf automake"
+install=""
+subpackages=""
+source="http://downloads.sourceforge.net/nwipe/nwipe-$pkgver.tar.gz"
+_builddir="$srcdir"/nwipe-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ aclocal && autoconf && autoheader && automake --add-missing
+}
+
+build() {
+ cd "$_builddir"
+ CFLAGS="$CFLAGS -D_GNU_SOURCE" \
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="98487303370494b65df47e98649a054a nwipe-0.16.tar.gz"
+sha256sums="509aebba371272764cacb446efce3f87b6a47bbc6e6717a1830b5bed4e0fb4bc nwipe-0.16.tar.gz"
+sha512sums="65985b9b963e2815c5aecdf1d728c802e4b4e97cd496a8e725e8a4c9040dd20ef7f727bfcd0fc012a1f5484f79322831c932e5e4c025c7a1704a687fd956d42a nwipe-0.16.tar.gz"