aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/opal/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/opal/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/opal/APKBUILD')
-rw-r--r--unmaintained/opal/APKBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/unmaintained/opal/APKBUILD b/unmaintained/opal/APKBUILD
new file mode 100644
index 0000000000..ff018007b8
--- /dev/null
+++ b/unmaintained/opal/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: Mika Havela
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=opal
+pkgver=3.10.10
+pkgrel=0
+pkgdesc="Open Phone Abstraction Library"
+url="http://www.opalvoip.org/"
+arch="all"
+license="MPLv1.0"
+depends=""
+depends_dev="openssl-dev ptlib-dev speex-dev"
+makedepends="$depends_dev sdl-dev libtheora-dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://download.gnome.org/sources/opal/3.10/opal-$pkgver.tar.xz"
+
+_builddir="$srcdir"/opal-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+dev() {
+ default_dev
+ mkdir -p "$subpkgdir"/usr/share/opal/make
+ install -m644 "$_builddir"/opal_defs.mak \
+ "$_builddir"/opal_inc.mak \
+ "$subpkgdir"/usr/share/opal/make
+}
+
+md5sums="6efa1b4c5e0ad6460019b4c6df0898d7 opal-3.10.10.tar.xz"
+sha256sums="f208985003461b2743575eccac13ad890b3e5baac35b68ddef17162460aff864 opal-3.10.10.tar.xz"
+sha512sums="b72a058e001b5bf69de64467e6fc90280ec83bf31f46fa9f504e921b4702450f8732c7df333b9677e04cf1d33d27efbe22056211da94b879e013f5d7bcaa8465 opal-3.10.10.tar.xz"