aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/openlldp
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/openlldp
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/openlldp')
-rw-r--r--unmaintained/openlldp/APKBUILD58
-rw-r--r--unmaintained/openlldp/openlldp.confd2
-rwxr-xr-xunmaintained/openlldp/openlldp.initd24
-rw-r--r--unmaintained/openlldp/procfs.patch19
4 files changed, 103 insertions, 0 deletions
diff --git a/unmaintained/openlldp/APKBUILD b/unmaintained/openlldp/APKBUILD
new file mode 100644
index 0000000000..868c8870a7
--- /dev/null
+++ b/unmaintained/openlldp/APKBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=openlldp
+pkgver=0.4a
+_realver=${pkgver/a/alpha}
+pkgrel=2
+pkgdesc="Open Source implementation of the IEEE standard 802.1AB Link Layer Discovery Protocol (LLDP)"
+url="http://openlldp.sourceforge.net/"
+arch="all"
+license="GPL"
+depends=
+makedepends="autoconf automake"
+install=
+subpackages=""
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$_realver.tar.gz
+ procfs.patch
+ $pkgname.initd
+ $pkgname.confd"
+
+_builddir="$srcdir"/$pkgname-$_realver
+
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ aclocal && autoconf && automake --add-missing || return 1
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+ install -m755 -D ../../$pkgname.initd "$pkgdir"/etc/init.d/lldpd
+ install -m644 -D ../../$pkgname.confd "$pkgdir"/etc/conf.d/lldpd
+}
+
+md5sums="f48ffd632b96246cbf0f5c485dea3b01 openlldp-0.4alpha.tar.gz
+c1e81927d2ea0ebcfaee52e79e9122c7 procfs.patch
+7e1a489d8ccdd204cac68ce87e0ce360 openlldp.initd
+7ac497e5a8b2f68532816c5718f5bf62 openlldp.confd"
+sha256sums="266fd0e1a15f237cfb84ae2d225996836774ea3d4c1c2e2be3a2a6927a00f2b1 openlldp-0.4alpha.tar.gz
+57726f4157daec0388960c28a014796e8de18a6e1841565f2f64b14f5d4cd02f procfs.patch
+9f40286ae7fea71c6e8396bac4bce5e132f399275e5d3d5375ad463ed6b961a2 openlldp.initd
+01b523f3f5e1e9a99518ff309eb965406452aefb5bad024e3735970af884ad6c openlldp.confd"
+sha512sums="5418678a82703a373d5aaeda924ddd34ccb002b5bfc40f243e06f8201fb5407bd46b25aea6d6e2760a1065f0928025e33dcd1dfc42dd9b436d0e5467132b176a openlldp-0.4alpha.tar.gz
+1301d9d952ee0f3d8044e5eafd39ea16f9aa671597dc3fea0a57251beabd9e4f140171ddef5e32c5120d3ab42cfeb8878e863d63b4716313e4a94f24c75f0af2 procfs.patch
+93ef1fc1268321a5faf760d07758ee341ba965500c11625f52fc246580e86bff7fbd73a2c1dce276ba07a34a2468c6d4a1c0f2be6b98f425c8330573bb6baa30 openlldp.initd
+3817778b61974b17940ea058a1a46f19a432689cc43ab8e9f466bf71de496a61fd9c089a2be9f621556f1376f3a6ec7b8ee35ec820ecbbae0e520bea3079b804 openlldp.confd"
diff --git a/unmaintained/openlldp/openlldp.confd b/unmaintained/openlldp/openlldp.confd
new file mode 100644
index 0000000000..38d9613483
--- /dev/null
+++ b/unmaintained/openlldp/openlldp.confd
@@ -0,0 +1,2 @@
+# Remove existing pid file at startup
+OPTS="-s"
diff --git a/unmaintained/openlldp/openlldp.initd b/unmaintained/openlldp/openlldp.initd
new file mode 100755
index 0000000000..4ab856addc
--- /dev/null
+++ b/unmaintained/openlldp/openlldp.initd
@@ -0,0 +1,24 @@
+#!/sbin/runscript
+
+NAME="lldpd"
+DAEMON="/usr/sbin/$NAME"
+pidfile=/var/run/$NAME.pid
+
+depend() {
+ need net
+ after firewall
+}
+
+start() {
+ ebegin "Starting ${NAME}"
+ start-stop-daemon --start --quiet --pidfile ${pidfile} \
+ --exec ${DAEMON} -- ${OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${NAME}"
+ start-stop-daemon --stop --exec ${DAEMON}
+ eend $?
+}
+
diff --git a/unmaintained/openlldp/procfs.patch b/unmaintained/openlldp/procfs.patch
new file mode 100644
index 0000000000..56ea7b5d31
--- /dev/null
+++ b/unmaintained/openlldp/procfs.patch
@@ -0,0 +1,19 @@
+--- ./configure.ac.orig
++++ ./configure.ac
+@@ -188,16 +188,6 @@
+ AC_MSG_CHECKING([for platform OS])
+ AC_MSG_RESULT($platform)
+
+-AS_IF([test $framer = "linux"],
+- [ MORELIBS="${MORELIBS} -lm"
+- AC_MSG_CHECKING([for procfs support])
+- if test -r /proc/net/dev; then
+- AC_MSG_RESULT(okay)
+- else
+- AC_MSG_ERROR([You must have ProcFS enabled in your kernel!]);
+- fi],
+- [])
+-
+ AS_IF([test $framer = "generic"],
+ MORELIBS="${MORELIBS} -lwpcap -lpcap -ldnet",
+ [])