aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/openvas-cli
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-04-10 10:09:29 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-04-10 10:09:35 +0000
commit9d48859cf28b715cb2de61f4b0537defa2635907 (patch)
treea5a073b3d9d168ed5605d590142fb4a7a1481339 /unmaintained/openvas-cli
parentc36e066edfd9f4c4c86f6c4b69bab21d58e914cc (diff)
downloadaports-9d48859cf28b715cb2de61f4b0537defa2635907.tar.bz2
aports-9d48859cf28b715cb2de61f4b0537defa2635907.tar.xz
unmaintained/openvas-cli: do not build with new gvm-libs
Diffstat (limited to 'unmaintained/openvas-cli')
-rw-r--r--unmaintained/openvas-cli/001-fortify-source.patch16
-rw-r--r--unmaintained/openvas-cli/APKBUILD39
2 files changed, 55 insertions, 0 deletions
diff --git a/unmaintained/openvas-cli/001-fortify-source.patch b/unmaintained/openvas-cli/001-fortify-source.patch
new file mode 100644
index 0000000000..49a9cdfd97
--- /dev/null
+++ b/unmaintained/openvas-cli/001-fortify-source.patch
@@ -0,0 +1,16 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index db7cb9b..3681573 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -190,9 +190,9 @@ configure_file (VERSION.in VERSION)
+ ## Program
+
+ if (MINGW)
+- set (HARDENING_FLAGS "-Wformat -Wformat-security -O2 -D_FORTIFY_SOURCE=2")
++ set (HARDENING_FLAGS "-Wformat -Wformat-security -O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2")
+ else (MINGW)
+- set (HARDENING_FLAGS "-Wformat -Wformat-security -O2 -D_FORTIFY_SOURCE=2 -fstack-protector")
++ set (HARDENING_FLAGS "-Wformat -Wformat-security -O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector")
+ set (LINKER_HARDENING_FLAGS "-Wl,-z,relro -Wl,-z,now")
+ endif (MINGW)
+
diff --git a/unmaintained/openvas-cli/APKBUILD b/unmaintained/openvas-cli/APKBUILD
new file mode 100644
index 0000000000..b43a1486a0
--- /dev/null
+++ b/unmaintained/openvas-cli/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=openvas-cli
+pkgver=1.4.5
+pkgrel=4
+_pkgid=2397
+pkgdesc="The OpenVAS Command-Line Interface"
+url="http://www.openvas.org"
+arch="all"
+license="GPL"
+makedepends="openvas-libraries-dev cmake doxygen xmltoman graphviz"
+subpackages="$pkgname-doc"
+source="http://wald.intevation.org/frs/download.php/$_pkgid/$pkgname-$pkgver.tar.gz
+ 001-fortify-source.patch"
+
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DSYSCONFDIR=/etc \
+ -DLOCALSTATEDIR=/var .
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir/" install
+}
+
+sha512sums="35ec391d1e25bfe1a49507b9e2ec69243411a6e839232334bb0f2eed26750a159942b7d14528fab9e57e1c7d7bf40fa087686444168ced4e4281ad78f2aeae85 openvas-cli-1.4.5.tar.gz
+979714b5625b87ec559be6d7520152c713b5455a401e50350b5c342b3769cfa83946a31dd963300cb0b0276fdc28f27ea66854563bec1a744322b6c268202935 001-fortify-source.patch"