aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/oxygen-icons
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/oxygen-icons
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/oxygen-icons')
-rw-r--r--unmaintained/oxygen-icons/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/unmaintained/oxygen-icons/APKBUILD b/unmaintained/oxygen-icons/APKBUILD
new file mode 100644
index 0000000000..9ba50e41d7
--- /dev/null
+++ b/unmaintained/oxygen-icons/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer:
+pkgname=oxygen-icons
+pkgver=4.13.3
+pkgrel=0
+pkgdesc="oxygen icon set"
+url="http://www.oxygen-icons.org/"
+arch="noarch"
+license="LGPL"
+depends=
+depends_dev="cmake"
+makedepends="$depends_dev automoc4"
+install=""
+subpackages=""
+source="ftp://ftp.kde.org/pub/kde/stable/4.13.3/src/${pkgname}-${pkgver}.tar.xz"
+install_if="kdebase-workspace"
+
+_builddir="$srcdir"/${pkgname}-${pkgver}
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ mkdir "$_builddir"/build
+}
+
+build() {
+ cd "$_builddir"/build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DKDE4_BUILD_TESTS=OFF \
+ "$_builddir" || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"/build
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="25d5e555aa82a98ee82c6ec3b23a2763 oxygen-icons-4.13.3.tar.xz"
+sha256sums="1478e0224020a881bea93e7c84cde9c1592ee299333f3e762ffa8f7229641075 oxygen-icons-4.13.3.tar.xz"
+sha512sums="c8b4c97d714190a1b02b75d4980aab62d4d686d0a9b3fc886c7d89de6f9478f0b4572c3a4d890304e1d51a4dd2464c1cd59e7c9f92cee02a3c866110c2bb2147 oxygen-icons-4.13.3.tar.xz"