aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/parcellite
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/parcellite
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/parcellite')
-rw-r--r--unmaintained/parcellite/APKBUILD49
-rw-r--r--unmaintained/parcellite/fix-crash.patch11
2 files changed, 60 insertions, 0 deletions
diff --git a/unmaintained/parcellite/APKBUILD b/unmaintained/parcellite/APKBUILD
new file mode 100644
index 0000000000..6d2f92a7e5
--- /dev/null
+++ b/unmaintained/parcellite/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: August Klein <amatcoder@gmail.com>
+# Maintainer: August Klein <amatcoder@gmail.com>
+pkgname=parcellite
+pkgver=1.1.9
+pkgrel=0
+pkgdesc="A lightweight GTK+ clipboard manager"
+url="http://parcellite.sourceforge.net"
+arch="all"
+license="GPL3"
+depends=""
+depends_dev="gtk+2.0-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-lang $pkgname-doc"
+source="http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz
+ fix-crash.patch"
+
+_builddir="$srcdir"/${pkgname}-${pkgver}
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="6c3b70165c2dee9341a81a2a8481e446 parcellite-1.1.9.tar.gz
+f2cc1986e573d49c92ea3d81efd5d574 fix-crash.patch"
+sha256sums="cba89585082eebbe848ac1c0023cc71a0184c0db24ebc5f8a21039e46d7f11d4 parcellite-1.1.9.tar.gz
+8fe1e86958d371c9fa9474fe64b203ed483f636f3f98152237402ea84b2d2cbd fix-crash.patch"
+sha512sums="24721dbd4f049f65a40f4e4c6914344062d49dfb50e3cf6496c6f14d9aff02bef5b88d3a714e8176955c84b1324c9ca1f35b389e8033d1232dd3c802c40e32bf parcellite-1.1.9.tar.gz
+3cfbf5e22ff33d4c33696fb2a8e4c24b91ded0a36b30188e47f56532e315184eed69e66f3dc4dd9cd1dcaa1310d9343e79d19238012acf76fb36418766e007c9 fix-crash.patch"
diff --git a/unmaintained/parcellite/fix-crash.patch b/unmaintained/parcellite/fix-crash.patch
new file mode 100644
index 0000000000..a8ce712e1a
--- /dev/null
+++ b/unmaintained/parcellite/fix-crash.patch
@@ -0,0 +1,11 @@
+--- a/src/preferences.c.orig 2013-11-11 14:39:32.000000000 +0400
++++ b/src/preferences.c 2013-11-11 14:40:03.970776522 +0400
+@@ -381,7 +381,7 @@
+ }
+ /**now go through and make sure we have no duplicates */
+ for (i=0;NULL != keylist[i].name; ++i){
+- if(0 != keylist[i].keyval[0]){
++ if(NULL != keylist[i].keyval && 0 != keylist[i].keyval[0]){
+ /**see if it exists elsewhere */
+ for (l=0;NULL != keylist[l].name; ++l){
+ if(l!=i && 0 != keylist[l].keyval[0]){