aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/partclone
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-05-11 16:43:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-05-11 16:45:47 +0000
commit315ddd26b78d81b1c2f0c1d2a85da338b00fdb25 (patch)
tree47205a7adb60694996874da8c3fc720dcd920501 /unmaintained/partclone
parentaacae4a7b4456b75cbc938f7656cc7118b1e8646 (diff)
downloadaports-315ddd26b78d81b1c2f0c1d2a85da338b00fdb25.tar.bz2
aports-315ddd26b78d81b1c2f0c1d2a85da338b00fdb25.tar.xz
unmaintained/: Purge packages unmaintained since v3.0
Removes packages that have been in aports/unmaintained since the 3.0-stable branch. Alpine Linux v3.0 was released on 2014-06-04 and EOL on 2016-05-01, so these packages have not been touched since at least 23 months. The files can still be recovered from the 3.3-stable branch.
Diffstat (limited to 'unmaintained/partclone')
-rw-r--r--unmaintained/partclone/APKBUILD68
-rw-r--r--unmaintained/partclone/memtrace.patch14
2 files changed, 0 insertions, 82 deletions
diff --git a/unmaintained/partclone/APKBUILD b/unmaintained/partclone/APKBUILD
deleted file mode 100644
index ec56ba81df..0000000000
--- a/unmaintained/partclone/APKBUILD
+++ /dev/null
@@ -1,68 +0,0 @@
-# Contributor: Leonardo Arena <rnarld@alpinelinux.org>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=partclone
-pkgver=0.2.38
-pkgrel=1
-pkgdesc="Partition cloning tool"
-url="http://partclone.org/"
-arch="all"
-license="GPL2+"
-depends=
-makedepends="e2fsprogs-dev ncurses-dev ntfsprogs-dev"
-install=""
-subpackages="$pkgname-doc"
-source="http://downloads.sourceforge.net/project/partclone/stable/$pkgver/partclone_$pkgver.tar.gz
- memtrace.patch"
-
-# TODO:
-# libreiserfs: http://reiserfs.linux.kiev.ua
-#
-_builddir="$srcdir"/partclone-$pkgver
-
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
-# --enable-all enable all supported file system
-# --enable-extfs enable ext2/3/4 file system
-# --enable-xfs enable XFS file system
-# --enable-reiserfs enable REISERFS 3.6/3.6 file system
-# --enable-reiser4 enable Reiser4 file system
-# --enable-hfsp enable HFS plus file system
-# --enable-fat enable FAT file system
-# --enable-ntfs enable NTFS file system
-# --enable-ufs enable UFS(1/2) file system
-# --enable-vmfs enable vmfs file system
-# --enable-jfs enable jfs file system
-# --enable-btrfs enable btrfs file system
-## --enable-xfs \
- ac_cv_lib_rt_aio_init=yes ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstatedir=/var \
- --enable-extfs \
- --enable-fat \
- --enable-ntfs \
- --enable-ncursesw \
- --disable-nls \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
-}
-
-md5sums="8577ac06ad54a829435f272eecedfa14 partclone_0.2.38.tar.gz
-83dfb01e5d68795266726826a49a2de8 memtrace.patch"
diff --git a/unmaintained/partclone/memtrace.patch b/unmaintained/partclone/memtrace.patch
deleted file mode 100644
index 9c8ba9af1b..0000000000
--- a/unmaintained/partclone/memtrace.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/src/main.c b/src/main.c
-index 2fb6b58..8f079f2 100644
---- a/src/main.c
-+++ b/src/main.c
-@@ -20,7 +20,9 @@
- #include <sys/types.h>
- #include <stdio.h>
- #include <stdlib.h>
-+#ifdef HAVE_MEMTRACE
- #include <mcheck.h>
-+#endif
- #include <stdint.h>
- #include <stdarg.h>
- #include <string.h>