aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/perl-apache-session-browseable
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/perl-apache-session-browseable
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/perl-apache-session-browseable')
-rw-r--r--unmaintained/perl-apache-session-browseable/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/unmaintained/perl-apache-session-browseable/APKBUILD b/unmaintained/perl-apache-session-browseable/APKBUILD
new file mode 100644
index 0000000000..d17313e652
--- /dev/null
+++ b/unmaintained/perl-apache-session-browseable/APKBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Xavier Guimard <x.guimard@free.fr>
+pkgname=perl-apache-session-browseable
+_pkgreal=Apache-Session-Browseable
+pkgver=1.1
+pkgrel=0
+pkgdesc="An implementation of Apache::Session"
+url="https://metacpan.org/pod/Apache::Session::LDAP"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-apache-session"
+cpanmakedepends="perl-module-build-tiny perl-dbd-sqlite perl-dbi"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends perl-module-build"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/C/CO/COUDOT/Apache-Session-Browseable-1.1.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Build.PL --installdirs vendor
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ ./Build && ./Build test
+}
+
+package() {
+ cd "$_builddir"
+ ./Build install --destdir "$pkgdir" || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="49be2eb67e029c78344149ab20815eec Apache-Session-Browseable-1.1.tar.gz"
+sha256sums="d71924fe9b10bec196f680008fb94451b59348a6ff64e04d12c2b8ef14a178e3 Apache-Session-Browseable-1.1.tar.gz"
+sha512sums="0b5cca3963179127bb988cfa4c8dd1db58256285a1b1120b99b2688aa5dbbad3e2d92c3d70acccf66d3c83ae232158978dbdbfb72d158c6af597dbbaa754c279 Apache-Session-Browseable-1.1.tar.gz"