aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/perl-net-whois-ip/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/perl-net-whois-ip/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/perl-net-whois-ip/APKBUILD')
-rw-r--r--unmaintained/perl-net-whois-ip/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/unmaintained/perl-net-whois-ip/APKBUILD b/unmaintained/perl-net-whois-ip/APKBUILD
new file mode 100644
index 0000000000..9d89270ecd
--- /dev/null
+++ b/unmaintained/perl-net-whois-ip/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=perl-net-whois-ip
+_realname=Net-Whois-IP
+pkgver=1.19
+pkgrel=0
+pkgdesc="Perl extension for looking up the whois information for ip addresses"
+url="http://search.cpan.org/~bschmitz/Net-Whois-IP/"
+arch="noarch"
+license="PerlArtistic"
+depends="perl "
+depends_dev=""
+makedepends="perl-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/B/BS/BSCHMITZ/$_realname-$pkgver.tar.gz"
+_builddir="$srcdir"/$_realname-$pkgver
+
+build() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="06b319f4da85f13b3ea757f589f37e17 Net-Whois-IP-1.19.tar.gz"
+sha256sums="f09bdfa0f1d2665b534826b5f3a8662349930eed2998efe4d8dbf98813147222 Net-Whois-IP-1.19.tar.gz"
+sha512sums="80d1be9dc6c8e9da74df97524f1a804f6ab64f1e016509944b1ba970c2a508e46cd6d633c6cfc2e9fa5d3fc8240500f81cbc90a27bdeab26cb7b590ba97758ae Net-Whois-IP-1.19.tar.gz"