aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/perl-test-compile/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/perl-test-compile/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/perl-test-compile/APKBUILD')
-rw-r--r--unmaintained/perl-test-compile/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/unmaintained/perl-test-compile/APKBUILD b/unmaintained/perl-test-compile/APKBUILD
new file mode 100644
index 0000000000..357b20674c
--- /dev/null
+++ b/unmaintained/perl-test-compile/APKBUILD
@@ -0,0 +1,45 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=perl-test-compile
+_pkgreal=Test-Compile
+pkgver=v1.3.0
+pkgrel=0
+pkgdesc="Perl module for Test-Compile"
+url="http://search.cpan.org/dist/Test-Compile/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends="perl-module-build perl-devel-checkos perl-module-build
+ perl-test-warnings perl-universal-require"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/E/EG/EGILES/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ if [ -e Build.PL ]; then
+ perl Build.PL installdirs=vendor || return 1
+ else
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ fi
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ ./Build && ./Build test
+}
+
+package() {
+ cd "$_builddir"
+ ./Build install destdir="$pkgdir" || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="c7e8c9255d818823d440ac640527e7f8 Test-Compile-v1.3.0.tar.gz"
+sha256sums="77527e9477ac5260443c756367a7f7bc3d8f6c6ebbc561b0b2fb3f79303bad33 Test-Compile-v1.3.0.tar.gz"
+sha512sums="58396ed37a668ad005955193dfdad435d4b92f16334ed83f1ec5de8e1046bef8eec452ccefa277311f8eb903c7872fcc6ebacfeba112621f8b8ca05841089ef8 Test-Compile-v1.3.0.tar.gz"