aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/php7-pear-net_smtp
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2019-12-16 22:42:47 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2019-12-18 19:51:53 +0000
commit34d6671c3b0954c116253244b405fc9581788a95 (patch)
tree922b8b68b47f1c50cb5edb2191b3b97b6614ba7e /unmaintained/php7-pear-net_smtp
parent4f41af115f2fe395e2de01e5ee07a53dbbfa38a1 (diff)
downloadaports-34d6671c3b0954c116253244b405fc9581788a95.tar.bz2
aports-34d6671c3b0954c116253244b405fc9581788a95.tar.xz
community/roundcubemail: move to unmaintained with all dependencies
Closes #10933
Diffstat (limited to 'unmaintained/php7-pear-net_smtp')
-rw-r--r--unmaintained/php7-pear-net_smtp/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/unmaintained/php7-pear-net_smtp/APKBUILD b/unmaintained/php7-pear-net_smtp/APKBUILD
new file mode 100644
index 0000000000..077912cff6
--- /dev/null
+++ b/unmaintained/php7-pear-net_smtp/APKBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+_php=php7
+pkgname=${_php}-pear-net_smtp
+_pkgreal=Net_SMTP
+pkgver=1.9.0
+pkgrel=0
+pkgdesc="An implementation of the SMTP protocol"
+url="http://pear.php.net/package/Net_SMTP"
+arch="noarch"
+license="BSD-2-Clause"
+depends="${_php}-pear ${_php}-pear-net_socket"
+options="!check"
+subpackages="$pkgname-doc"
+source="http://download.pear.php.net/package/$_pkgreal-$pkgver.tgz"
+builddir="$srcdir"/$_pkgreal-$pkgver
+
+_phpdir="usr/share/${_php}"
+
+package() {
+ cd "$builddir"
+ for dir in doc example test; do
+ install -d "$pkgdir"/$_phpdir/$dir/$_pkgreal
+ done
+ mv docs "$pkgdir"/$_phpdir/doc/$_pkgreal
+ mv examples "$pkgdir"/$_phpdir/example/$_pkgreal
+ mv tests "$pkgdir"/$_phpdir/test/$_pkgreal
+ install -d "$pkgdir"/$_phpdir/PEAR
+ mv Net "$pkgdir"/$_phpdir/PEAR
+ install -Dm0644 LICENSE "$pkgdir"/$_phpdir/doc/$_pkgreal/LICENSE
+}
+
+doc() {
+ cd "$builddir"
+ install -d "$subpkgdir"/$_phpdir/doc
+ mv "$pkgdir"/$_phpdir/doc/$_pkgreal \
+ "$subpkgdir"/$_phpdir/doc
+}
+
+sha512sums="fb28bbf07e54d71d1a82d59b137e4905c77b5600c10cf7760890ec708fc9e6df9d47715cf6808569f88603fac80c1cfdd7c4f3893efe7ac7aecaac47ba849ec2 Net_SMTP-1.9.0.tgz"