aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/phppgadmin
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/phppgadmin
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/phppgadmin')
-rw-r--r--unmaintained/phppgadmin/APKBUILD72
-rw-r--r--unmaintained/phppgadmin/phppgadmin.apache2.conf7
-rw-r--r--unmaintained/phppgadmin/phppgadmin.post-install16
3 files changed, 95 insertions, 0 deletions
diff --git a/unmaintained/phppgadmin/APKBUILD b/unmaintained/phppgadmin/APKBUILD
new file mode 100644
index 0000000000..f6a3405448
--- /dev/null
+++ b/unmaintained/phppgadmin/APKBUILD
@@ -0,0 +1,72 @@
+# Contributor: Matt Smith <mcs@darkregion.net>
+# Maintainer: Matt Smith <mcs@darkregion.net>
+pkgname=phppgadmin
+_pkgname=phpPgAdmin
+pkgver=5.1
+pkgrel=0
+pkgdesc="A Web-based PHP tool for administering PostgreSQL"
+url="http://phppgadmin.sourceforge.net/"
+arch="noarch"
+license="GPL2+"
+depends="php php-pgsql php-zlib php-ctype postgresql"
+depends_dev=""
+makedepends="$depends_dev"
+install="$pkgname.post-install"
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/phppgadmin/$_pkgname-$pkgver.tar.gz
+ phppgadmin.apache2.conf
+ "
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ return 0
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr/share/webapps/$pkgname "$pkgdir"/etc/$pkgname \
+ || return 1
+
+ # copy phppgadmin
+ cp -ra "$_builddir"/* "$pkgdir"/usr/share/webapps/$pkgname/ \
+ || return 1
+
+ # install the config
+ install -m440 \
+ "$pkgdir"/usr/share/webapps/$pkgname/conf/config.inc.php-dist \
+ "$pkgdir"/etc/$pkgname/config.inc.php || return 1
+ rm -rf "$pkgdir"/usr/share/webapps/$pkgname/conf/ || return 1
+ ln -fs /etc/phppgadmin/ "$pkgdir"/usr/share/webapps/$pkgname/conf \
+ || return 1
+
+ # install the apache2 config
+ install -Dm644 "$srcdir"/$pkgname.apache2.conf \
+ "$pkgdir"/etc/apache2/conf.d/$pkgname.conf || return 1
+}
+
+doc() {
+ mkdir -p "$subpkgdir"/usr/share/doc/$pkgname || return 1
+ _docs="CREDITS DEVELOPERS FAQ HISTORY INSTALL LICENSE TODO \
+ TRANSLATORS help"
+ for _doc in $_docs; do
+ mv "$pkgdir"/usr/share/webapps/$pkgname/$_doc \
+ "$subpkgdir"/usr/share/doc/$pkgname/ || return 1
+ done
+}
+
+md5sums="554c94f5b38a1c6e8327ec3aa4cc6538 phpPgAdmin-5.1.tar.gz
+670eec89bbe794a50d36c80f02608708 phppgadmin.apache2.conf"
+sha256sums="42294e7b19d3b4003912eaad9a34df4096c0380871aedce152aa13d4955878a5 phpPgAdmin-5.1.tar.gz
+fb8fe69a0f8bd2efd93e697d5071273cad508f5c46242c112966ec65662c678f phppgadmin.apache2.conf"
+sha512sums="4a9502f234dd09487b016130217bc052899b9ba2ced953133defb0d095e9853570b766aa96bbdb4c315e42ca73002515fb8755166558e79e833b433eebd9bc22 phpPgAdmin-5.1.tar.gz
+7dbc314c1c1dd3ab14a19323f01650fa1ef498e511ed4a05dac57438c9b926c7af0ad4260059b7cc971572557ef7001bcd110fbf0fa466e153f6125e38c15aeb phppgadmin.apache2.conf"
diff --git a/unmaintained/phppgadmin/phppgadmin.apache2.conf b/unmaintained/phppgadmin/phppgadmin.apache2.conf
new file mode 100644
index 0000000000..b69e01b22d
--- /dev/null
+++ b/unmaintained/phppgadmin/phppgadmin.apache2.conf
@@ -0,0 +1,7 @@
+Alias /phppgadmin "/usr/share/webapps/phppgadmin"
+<Directory "/usr/share/webapps/phppgadmin">
+ AllowOverride All
+ Options FollowSymlinks
+ Order allow,deny
+ Allow from all
+</Directory>
diff --git a/unmaintained/phppgadmin/phppgadmin.post-install b/unmaintained/phppgadmin/phppgadmin.post-install
new file mode 100644
index 0000000000..f9650a192a
--- /dev/null
+++ b/unmaintained/phppgadmin/phppgadmin.post-install
@@ -0,0 +1,16 @@
+#!/bin/sh
+
+echo "*" >&2
+echo "* phppgadmin has been installed to:" >&2
+echo "* /usr/share/webapps/phppgadmin" >&2
+echo "* phppgadmin config file has been installed to:" >&2
+echo "* /etc/phppgadmin/config.inc.php" >&2
+echo "* If you use apache2:" >&2
+echo "* 1) Change the ownership of the config directory:" >&2
+echo "* chown -R apache:apache /etc/phppgadmin" >&2
+echo "* 2) See if you need to modify the apache2 config:" >&2
+echo "* /etc/apache2/conf.d/phppgadmin.conf" >&2
+echo "* 3) Restart apache2 when done." >&2
+echo "*" >&2
+
+exit 0