aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/postler
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/postler
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/postler')
-rw-r--r--unmaintained/postler/APKBUILD42
-rw-r--r--unmaintained/postler/inet_ntoa.patch10
2 files changed, 52 insertions, 0 deletions
diff --git a/unmaintained/postler/APKBUILD b/unmaintained/postler/APKBUILD
new file mode 100644
index 0000000000..e8f3117388
--- /dev/null
+++ b/unmaintained/postler/APKBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=postler
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Email client"
+url="https://launchpad.net/postler/"
+arch=""
+license="LGPL2.1"
+depends="msmtp"
+makedepends="gtk+-dev webkit-dev libunique-dev libnotify-dev libcanberra-dev
+ python vala db-dev openssl-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://archive.xfce.org/src/apps/postler/0.1/postler-$pkgver.tar.bz2
+ inet_ntoa.patch"
+
+_builddir="$srcdir"/postler-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./waf configure --prefix=/usr \
+ --disable-libindicate \
+ || return 1
+ ./waf build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ ./waf install --destdir="$pkgdir" || return 1
+}
+
+md5sums="02e502c9f4a4b92e4ace32d9e268f06d postler-0.1.1.tar.bz2
+06bb9bb2d1a809b6e58b2a5012393151 inet_ntoa.patch"
diff --git a/unmaintained/postler/inet_ntoa.patch b/unmaintained/postler/inet_ntoa.patch
new file mode 100644
index 0000000000..bbb0969bc2
--- /dev/null
+++ b/unmaintained/postler/inet_ntoa.patch
@@ -0,0 +1,10 @@
+--- a/wscript
++++ b/wscript
+@@ -141,7 +141,6 @@
+ includes=['/usr/local/include/db42'],
+ libpath=['/usr/local/lib/db42'], lib='db', mandatory=True)
+ else:
+- check_function ('inet_ntoa', 'arpa/inet.h', 'nsl')
+ check_function ('dlopen', 'dlfcn.h', 'dl')
+ check_function ('db_create', 'db.h', 'db')
+ check_pkg ('openssl')