aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/py-des/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/py-des/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/py-des/APKBUILD')
-rw-r--r--unmaintained/py-des/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/unmaintained/py-des/APKBUILD b/unmaintained/py-des/APKBUILD
new file mode 100644
index 0000000000..6ff5dcc966
--- /dev/null
+++ b/unmaintained/py-des/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-des
+_pkgname=pyDes
+pkgver=2.0.1
+pkgrel=0
+pkgdesc="A Python implementation of DES and TRIPLE DES encryption algorithms"
+url="http://twhiteman.netfirms.com/des.html"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://twhiteman.netfirms.com/pyDES/$_pkgname-$pkgver.zip"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="90f06a24a1ee73fb0e235571d51c287a pyDes-2.0.1.zip"
+sha256sums="9cc6e509f627ef1c2d318730d22f1a33f23b41e1ec223b55a6420f2861266d76 pyDes-2.0.1.zip"
+sha512sums="d9107d532801ff2eb096eeb606c1b81fd68a76fccffdf095a6a2a79bd19815b4c366549989b6f4508c99a2f9afb063eceb7b0702e504ebb4d73dc8175057cb28 pyDes-2.0.1.zip"